Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Issue with Creating Ticket

Every time we have people create a ticket it takes them to a white screen (firefox) and displays a 500 internal server error. I don't know what the issue is, and if someone would be willing to help soon this would be really appreciated!

-Also, the information is going into the database, it just doesn't take them to the thank you page, or on the admin side, doesn't confirm the ticket was created.

Comments

  • First time I'm try to figure out about osTicket in my website, I got this error too '500 internal server error'. I think this is because the server busy or something. I dont know.
  • I have found out that it is not a server issue. It is an issue with my code, I'm just not sure what to look for, does anyone have any ideas? I know that it gives the 500 internal server error whenever it: creates a new ticket (both client and admin side), edit an existing ticket, assign ticket, reply to the ticket, and many more. It also will not send out emails like it used to.

    Like I said I know there is an issue with the code I just don't know where to look, and if someone would be able to tell me where to look I would greatly appreciate it!

    **Just so everyone knows, the tickets are still created, it just takes whoever is creating the ticket to this 500 internal server error page and does not send emails. **
  • You have not really provided us enough information about your setup to be able to assist you (webserver and ver? php ver? etc.)

    You should consult your php error log and post the errors that you are receiving. If you cannot enable php error logging you can turn on error logging in osTicket by editing the main.inc.php.

    on line 43 through 45 locate:
        #Don't display errors
    ini_set('display_errors', 0);
    ini_set('display_startup_errors', 0);


    and change it to:
        #Don't display errors
    ini_set('display_errors', 1);
    ini_set('display_startup_errors', 1);


    And post the errors reported here.
  • I was able to figure out where I made the typo in the code.

    Thank you for the fast response though!
  • You're very welcome. It would have been sooner, but I got distracted in another tab and didn't realize that I hadn't hit "submit reply". :)
This discussion has been closed.