Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Not able to communicate with email server

Hi,

I have installed Osticket 1.6 ST from past 1 year, I have implemented some MODS. It was working fine till yesterday. I have upgraded the wamp server from 2.2d to 2.2e (php 5.4.3). I had to completely remove wamp and reinstall the new one again. Now osticket is not able to communicate with the mail server, so neither staff not user is able to open any ticket. When press submit to create ticket it gives a blank page after some time. But no email is send for the new ticket generated. The email settings, password and everything is fine as I am able to login to the webmail as well as I used the earlier settings only. I have even tried disabling the Anti Virus software but the result still is the same.

I am using SMTP, OS Version Server 2003

I know the coding is having some issue some where, but dont know where. No PHP Logs are also generated. Kindly help I m in deep trouble.

Below are some of the errors generated:

Deprecated: Assigning the return value of new by reference is deprecated in D:\wamp\www\Support\include\pear\Mail\smtp.php on line 322

Deprecated: Assigning the return value of new by reference is deprecated in D:\wamp\www\Support\include\pear\Mail\mimeDecode.php on line 335

Regards,
Vipin

Comments

  • Please provide Help

    Hi,

    Kindly provide your inputs on the above request, even after rolling back to earlier version of PHP osticket is not able to communicate with the mail server.
  • You should probably restore everything from backup. [wamp server from 2.2d, and osticket]

    You also need to make sure that your php installation is configured to talk to your mail server (see your php.ini specifically the [mail function] section.)

    1.6ST has quite a few things that PHP 5.4+ complains about in it.

    You should also consider upgrading to 1.7ST.
Sign In or Register to comment.