Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Clean Install 1.7 - Error parsing SQL schema

Upgrade from 1.6 to 1.7 didn't work, so I'm trying a clean install.

Created new database with collation UTF8_unicode_ci
Uploaded all files. Go to install page, checks ok. Rename ost-config.php
Enter user and database info... Continue... then get error


Error parsing SQL schema! Get help from developers (#4)

[CREATE TABLE `ost_api_key` ( `id` int(10) unsigned NOT NULL auto_increment, `isactive` tinyint(1) NOT NULL default ''1'', `ipaddr` varchar(64) NOT NULL, `apikey` varchar(255) NOT NULL, `can_create_tickets` TINYINT( 1 ) UNSIGNED NOT NULL DEFAULT ''1'', `can_exec_cron` TINYINT( 1 ) UNSIGNED NOT NULL DEFAULT ''1'', `notes` text, `updated` datetime NOT NULL, `created` datetime NOT NULL, PRIMARY KEY (`id`), KEY `ipaddr` (`ipaddr`), UNIQUE KEY `apikey` (`apikey`) ) ENGINE=MyISAM DEFAULT CHARSET=utf8] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '1'', `ipaddr` varchar(64) NOT NULL, `apikey` varchar(255) NOT NULL, `can_c' at line 3

???

Setup
Linux CentOS cpsrvd 11.34.1.14
MySQL 5.5.23
MySQL charset: UTF-8 Unicode (utf8)
PHP 5
Hosted on Hostgator

Comments

  • Any way of getting around this error?
  • IO would guess that your version of MySQL (5.5.x) doesn't like:

    tinyint(1) NOT NULL default ''1'',

    You could edit the install sql file and fix the query manually and then start over.  I imagine that if there is one thing like that there will be more though.
Sign In or Register to comment.