Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade failure 1.6ST to 1.7

Hello,

Tried to upgrade today (several times) but unsuccessful each time. PHP log says:
PHP Warning: Missing argument 2 for osTicket::logDebug(), 
called in /DIRECTORY_PATH/include/class.migrater.php on line 216 and
defined in /DIRECTORY_PATH/include/class.osticket.php on line 249,
referer: http://DOMAIN/scp/upgrade.php


syslog says
Error accessing SQL file 


Previous log to that is
Upgrader - 959a00e. applied


Any idea what is going wrong and more importantly how we can fix this?

Thanks

Comments

  • What version of PHP and MySQL are you running out of curiosity.
  • ntozier;40289 said:
    What version of PHP and MySQL are you running out of curiosity.
    PHP - 5.3.25-18
    MySQL - 5.5.31-16
    Apache - 2.2.15

    Had to restore to 1.6ST. I followed the instructions to the letter and tried 5 times without success. Each time I rolled back the dB and the directory structure as it was before attempting to upgrade and each time the upgrade failed. Not sure why. The log file and PHP error log (as above) are not particularly descriptive.
  • I've notified the devs to take a look at this case and see what they make of it. Hopefully one of them will get back to you.
  • ntozier;40346 said:
    I've notified the devs to take a look at this case and see what they make of it. Hopefully one of them will get back to you.
    Many thanks ntozier
  • I tried upgrading my v1.6 ST myself and got the exact same error right after the 959a00e update. I do not have the log files but sounds like this is a common error. Maby you could verbose the error message a little more to make it a little easier to see the error.

    Upgrader Error
    Error accessing SQL file
    http://domain.path/scp/ajax.php/upgrader

    Luckily I did make a backup so system was reverted quickly :) Will check back on this one, or just do a clean install.
  • I need to upgrade to 1.8X version, and see this topic:

    http://osticket.com/forum/discussion/76851/cannot-upgrade-from-1-6st-to-1-7-7#latest


    But when I try to upgrading from 1.6 ST to 1.7.0,  got the error:

    Upgrader Error

    [INSERT INTO `ost_team` (`lead_id`, `isenabled`, `noalerts`, `name`, `notes`, `created`, `updated`)
    VALUES (0, 1, 0, 'Level I Support', '', NOW(), NOW())] Duplicate entry 'Level I Support' for key 'name'


    My system:

    Debian 6.0.8

    PHP 5.3.3-7+squeeze19 with Suhosin-Patch (cli) (built: Feb 17 2014 10:10:23)
    mysql  Ver 14.14 Distrib 5.1.73, for debian-linux-gnu (x86_64) using readline 6.1
    Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze19

  • My advice would be to upgrade to current (1.9.3) not an outdated 1.7.x (or 1.8.x)
    Or to try upgrading from 1.6 to 1.7 (ST or .1, .2, or .3)  then try to upgrade to a newer version).
Sign In or Register to comment.