Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

exchange 2010 email polling

I have setup osticket 1.9 on an ubuntu base. I have an exchange 2010 server with a mailbox setup with an associated AD account. I go to admin panel > emails tab > emails then click on the email address i created matching the exchange mailbox i created. I fill out the fields per my network and exchange settings as show in the attachment and i get a "can't login to server" message. I can go to OWA and log in with the same credentials and get in just fine. i switch the protocol to secure pop and get the error "TLS/SSL failure for (IP address) SSL negotiation failed. When i try imap, i get the error "Server disables LOGIN, no recognized SASL authenticator". this is all i have left to get my system fully up and going.


  • Version of osTicket?
    Have you enabled IMAP or POP on your Exchange 2010?  (its disabled on default)
    Does your user account have privs to use those protocols?

    ps there is no attachment on this post.
  • 1.9.12 is the version.

    Yes, on my server, in the console i go to server configuration > client access and select the "pop3 and imap4" tab and both of them are enabled and running.

    Yes, on the mailbox properties, mailbox features, it show spop3 and imap4 both enabled on the account.

    i setup a receiver connector for this box server so exchange will accept emails from it, also.

    event viewer yields no results.

    email fetching in osticket is enabled.

  • You have a firewall on the webserver?  or Exchange?

    I use IMAP with my Exchange (we recently upgraded from 2007 to 2013) and have for years.  So it's likely something is preventing the connection or its a exchange configuration issue.  My main production servers of osTicket are still running 1.9.7 though.
  • only firewall on web server would be the ubuntu firewall and i believe it is set to allow all by default until custom rules are added. i disabled it for testing and still nothing. i get this at the top of the screen.

    not sure where else a setting would be wrong.
  • for some reason the images i post in the comment box or attachments dont seem to wanna says "invalid login. check pop settings"
  • I dont know if it will help, but you can turn on debug mode in osTicket. Admin panel -> Settings -> Default Log Level: Debug try again and see is any additional information shows up.  Exchange may have a connection log also that might shed some light on why the connection is failing.
  • This is what turning on debug on osticket gives me. not much to go off from.

  • edited January 2016

  • i turned off auto cron so only mail fetching is checked and now nothing is showing up in the osticket log. weird.
  • I have exchange 2013 and my osTicket 1.9.12 is running on Ubuntu.

    If you have Email Fetching 'Enable' checked, and 'Fetch on Auto-cron' not checked, and 'Default Log Level set to DEBUG, then you should be seeing an entry titled 'Cron Job'  in your osTicket system log every time the cron job fires.
    If it is not there, then you can be pretty confident the cron fetch is not running.

    As for the can't log into server message, I just wrote this in another thread, but I'll redo it here:
    Make sure that your chosen email account configuration works.

    First, verify the Default System Email
    (found under Admin panel, Settings - Emails -  Incoming Emails - Email
    Settings - ) is actually the account that you have set up on your exchange server
    to handle osTicket emails. (I didn't the first time I set it up)

    Then verify that that email account ( Your Tickets@**** account in Admin panel, Emails -  Emails ) can actually fetch from your exchange server. You
    could use Thunderbird running on on your Linux box to validate it.
    Although I use  Imap+SSL, in your case since you are using POP on
    port 110, set up Thunderbird with the same account credentials and using
    POP port 110  (it will want to default to IMAP and the SSL port, but
    you can use manual config to override it)

    If Thunderbird doesn't work, then the issue is probably your exchange server configuration.
  • edited January 2016
    charles - i turned on 'fetch auto-cron' and once i do that i get auto-cron logs which say this
  • edited January 2016
    this is what my Admin panel, Settings - Emails -  Incoming Emails - Email Settings looks like . tickets@****.*** is the email address i have setup in exchange.
  • edited January 2016

    >charles - i turned on 'fetch auto-cron' and once i do that i get auto-cron logs which say this

    Oops! I apologize for not being clear.  I meant that only 'Enable'
    should be checked, not that you should check 'Enable', and 'Fetch on auto-cron'. (I've seen 2 cases on this forum where having both boxes checked seemed to prevent fetching via cron from working, and unchecking the 'fetch auto-cron'  fixed it)

    >i turned off auto cron so only mail fetching is checked and now nothing is showing up in the osticket log

    Then as long as your logging level is set to DEBUG, you can be pretty confident the cron job is NOT running to fetch the email. 

    I've attached (hopefully) a screenshot showing what my email settings look like (same as yours), and what my debug log shows.  I've also attached my email address settings for the default email account in case you may find that helpful.

  • i deleted the tickets@*******.*** (tickets plural) and created a new one that is ticket@****.*** (singular) and verified i could log into it using outlook on a test vm and i was successful. i even sent a test email in which case the it was received in the outlook on the vm. When i tried both pop3 and imap, both secure and unsecure, it still would not let me log into the mailbox. i get this when i try imap /143. i am not even getting the "cron job" log listed in the log files.

  • " and verified i could log into it using outlook on a test vm and i was successful"
    this is not a true test.  This means that Outlook can talk to Exchange with it's proprietary MAPI protocol.
    MAPI is NOT IMAP (but arguably is fairly similar in some ways).

    According to your last screen shot you are configured to use IMAP.  You would need to use an IMAP client (thunderbird, or something else) to really test the connection.  It sounds to me like you have a configuration issue on your exchange server that is preventing IMAP connections or authentication at least.

    Maybe this will assist you:
Sign In or Register to comment.