Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Not sending or receiving emails

As the title suggests osticket is unable to receive or send messages. I am using osticket 1.9 and php 5.6. On the IMAP side of things. osticket is able to connect to the email and create a folder, but cannot receive messages. I also get this error when trying to authenticate through smtp. authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 Start TLS)]. I have searched the internet for a solution but have found nothing that works


  • 1.9 is ancient.  You should upgrade to current (1.9.12)

    That error means that TLS/SSL failed.
    You might want to try PHP 5.5 instead and see if that helps.
  • edited May 2016
    It wont let me downgrade.... Im using ubuntu 15.10. I am also using 1.9.12, forgot to mention the .12 bit XD. I tried downloading and installing php5.5 from ppa:ondrej/php. I purged anything remotely resembling php5.6 and removed anything tied with 5.6 in sources.list.d. Then entered apt-get install php5=5.5..... (insert source). It finds it but cant install it. So im stuck with php5.6...... Any thoughts on getting it to work with php5.6?
  • I read the thread and disabled the SMTP authentication. I still get the same error, but if I don't use authentication I get no error and still cant send.
  • anyone?
  • found solution. So php5.6 is absolute shit when it comes to smtp or email in general. Downgrading fixed all my email related problems. 

    First need to unistall php. apt-get purge php* (for debian systems)

  • So that's actually why I suggested that you try PHP 5.5 instead. :)
  • @ntozier as per our prior conversation that you were so dismissive about.

    I posted the information you suggested I post... 7 months ago........ Your suggesting to get it working was to:

    "So that's actually why I suggested that you try PHP 5.5 instead. :)"

    Don't get me wrong I am more than happy to downgrade to a version that works with the application, but I find it very frustrating when the product advertises it works with (insert software version) but it really doesn't. 

    This is a dev problem. A search pulled up multiple threads with people dealing with the starttls error. Here is a link to the search All "solved" starttls errors solutions are to downgrade to a previous version of php. This is a solution non-the-less, but it does not mean php5.6 is compatible with your app.

    If you can get it to work with php5.6 SHOW ME A WORKABLE SOLUTION. Please prove me to be an idiot. I would rather have osticket working on php5.6 then to be proven right that osticket is not fully compatible with it.
  • So...
    1. Are you still using an outdated version? (1.9.12 when there have been multple maint versions, and a new version released since then)

    2. Have you read the threads linked in this thread recently? (specifically comment 4)

    3. Do you remember posting that you found a fix and posted it here?
  • found a real solution. Had to search this forum a bit but found it!!!

    The problem IS in SMTP.php the file was not updated completely to incorporate php5.6.

    @Shaddana (sorry Shad for dragging you into this, but got to give you credit for the fix) found the problem in the SMTP.php config:
    I found in line 600 as follows :
            if ($tls && version_compare(PHP_VERSION, '5.1.0', '>=') &&
                extension_loaded('openssl') && isset($this->_esmtp['STARTTLS']) &&
                strncasecmp($this->host, 'ssl://', 6) !== 0)

    I modify to :
            if ($tls && version_compare(PHP_VERSION, '6.1.0', '>=') &&
                extension_loaded('openssl') && isset($this->_esmtp['STARTTLS']) &&
                strncasecmp($this->host, 'ssl://', 6) !== 0)

    It was in line 573 for me but, seems like a dev issue.....
  • Hi All,

    I have setup osTicket in production for my team to handle customers issue via ticket. It was working fine before a week but suddenly it stops fetching emails from MTA. Soemtimes it fetch emails and sometime it does not. It looks some issue , I have checked on my MTA there is no issue. Please suggest me to resolve this issue. I want osTicket to fetch emails in real time.

  • @krishna_ricoh please do not hijack other peoples threads. If you have a question, please start your own thread.

Sign In or Register to comment.