Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

OsTicket connecting to the wrong email server

I have setup the POP server and the cron job so that osticket can read the support emails and create the tickets. However I noticed a rather strange behaviour Ostickets connects to my old email server. I switched to an hosted email service since 1st April 2016 but it seems to be connecting to my previous email server. I checked the mx records for my domain and I get the correct ipaddress. The only way for osticket to connect to the old mail server is if it just assumes that the mails server always start with mail.mydomain.com (mydomain taken from the URL in the system settings and preferences). If this is the case then people who use hosted email services can never get their emails converted to tickets.

Has anyone faced this issue?

Best regards,

Sridhar
Tagged:

Comments

  • What is listed in the database table named email?  It should show your settings (at least it does in mine).
  • It does show mail.mydomain.com !

    Will change it but shouldn't osticket allow us to enter the emails server name and credentials rather than assuming that the emails server is mail.mydomain.com

    Best regards,

    Sridhar
  • I don't know.  I never tried to send an email until I configure the outgoing SMTP server, so I never needed to look at it.  I thought you had to configure it to send the email, or it wouldn't let you save your email entry for the alerts.
  • "shouldn't osticket allow us to enter the emails server name and
    credentials rather than assuming that the emails server is
    mail.mydomain.com"

    I have no idea why you would seem to think that osTicket doesn't let you enter the emails server name...

    Admin panel -> Emails -> click on the email you want to edit (or add a new one) see field labelled "Hostname".
Sign In or Register to comment.