Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

File is too large error.

I have found many users asking how to increase the file size but even through I’ve done all the steps I still can not get this to work.
My system:

osTicket Version v1.10-rc.2 (231f11e) — Up to date
Web Server Software Microsoft-IIS/8.0
MySQL Version 5.1.68
PHP Version 5.4.14

I have edited the following in my php.ini
upload_max_filesize
post_max_size

I can’t get attachments to work through email or through the web.  Through email I get an error in the thread “File Import Error” – “File size is too large”.  Through the web I get “File size is too large” “undefined”

Under the osTicket settings - Settings --> Tickets --> Attachments - It shows Maximum File Size as ---SMALL--- with a drop down menu - but nothing else is in the menu so I can't change it.

The file I was trying to use was only 633 KB – I’m not sure what I’m doing wrong.

Comments

  • After you edited your php.ini you restarted IIS right?
  • Yes thanks - I did restart IIS just to make sure - but the php.ini settings were in place before I installed osTicket.

  • What do you ahve at:
    Admin panel -> Settings -> System -> Attachment Storage and Settings?

    What do you have at:
    Admin panel -> Settings -> Tickets -> Ticket Attachment Settings -> Config?
  • Attachment Storage and Settings:

     - Store Attachments: "In the database" --> Clicking dropdown doesn't give me any other options.

     - Agent Maximum File Size: "Small" --> Clicking dropdown doesn't give me any other options.


    Ticket Attachment Settings -> Config:

     - Enable attachments is checked.

     - Maximum File Size: "Small" --> Clicking dropdown doesn't give me any other options.


  • Then you need to change your php.ini settings and restart IIS.
  • Did that - still same problem.
  • I don't know what to tell you then.  You either did it to the wrong php.ini, or you did it wrong, or you did not restart IIS. osTicket gets the max available size directly from PHP.
  • Ok figured it out - I'm using Owncloud on my server so I needed to be able to upload very large files.  In my PHP.ini I had it set to 5G - looks like osTicket doesn't like that.  As soon as I changed it to 100M - it worked.
Sign In or Register to comment.