Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

OS ticket and Ubuntu

Hi,

We are having a bit of a stange issue and guessing it's something to do with os ticket, but I'm sure you experts on here will have the solution. :)

We have just set up a new server on Ubuntu (latest stable version) and it's running LAMPs. Now we know this works as other php and myself scripts work, however it seems that is so ticket is not working and simply displaying a white screen. It does this on the copy of the files from our old server (ran Ubuntu 14.) Or if we even try and download and install the latest version of OS ticket.

We are convinced we must be doing something simple wrong, so hoping someone is able to help!?

Comments

  • Version of osTicket?
    Version of PHP?

    White screen = PHP error.
    You should either enable error displaying or consult your php error log.


  • Php 7.0 and 1.9.12 version of OS ticket.
  • That version of osTicket does not support PHP7.
    You will need to downgrade PHP to 5.4, 5.5, or 5.6.
  • Sounds silly, but is it easy to downgrade on Ubuntu?
  • I haven't tried that... but I presume that it would be something like:
    "apt-get remove php7" ought to remove 7.

    Afterwards "apt-get install php5" ought to install php5.  There are probably some other packages that you will want (php5-imap comes to mind). I would make note of what is being removed when you run the first command to so as to add the php5 versions.  Also so that you can switch back to php7 once 1.10 comes out [which supports php7].
  • How stable is 1.10? Would the database from 1.9.2 work with the 1.10 version? Willing to run the beta if it is fairly stable.
  • Also maybe a really silly question, but could we not install php 5.6 as well as php7 and both will operate? Or does it not work like that?
  • Q: How stable is 1.10?
    A: The new RC3 is very stable compared to RC2.  I would still recommend waiting for the final however.

    Q: Would the database from 1.9.2 work with the 1.10 version?
    A: Technically no.  1.10 would upgrade your database to the 1.10 format.  There is no going backwards from that unless you have a backup of a previous database.  This is why I always recommend taking a database backup before upgrading just in case.

    Q: could we not install php 5.6 as well as php7 and both will operate?
    A: Yes you can.  However then you have to tell which site which version of PHP to use.  Add in that you also would need to tell command line which version to use also. (for running Cron.php)  If you are comfortable with doing that feel free.  I've done both, but lean towards just one version installed personally.
  • Ok thanks for the reply. We have gone for the 1.10 version and seems to be working and meeting our needs. We reviewed and discussed your answers (very helpful) , considered our needs and thought that 1.10 at the moment meets them and at least we would be helping the osticket development by trying it out.

    So far it seems to be working. However how often is a beta update released? We do have a backup of the old dB as well , just incase.
  • Q: However how often is a beta update released?
    A: I don't have a good answer for this question.  Last year there were several released.  This year things have been slow development wise. 
Sign In or Register to comment.