Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Installation failing on fresh install of 1.7.0

[Edit] Solved the issue. See my second posting. [/Edit]
Hello,

Just downloaded the latest 1.7.0 version today. I'm not a nix guru by any stretch, but I do my research and follow doc's to the letter and that usually does the trick. Not this time.

After reading the install doc top to bottom, at http://osticket.com/wiki/Installation , I felt more than comfortable on what needed to be done. Everything listed is very standard and nothing I haven't seen before. It's actually very simple.

Steps Taken:
[LIST=1]
[*]I logged into Cpanel created my OSTicket DB, User, Pass and Permissions.
[*]Through Cpanel's file manager I created a "support" directory in the root of my "public_html".
[*]Following the download link in the install doc, I dl'ed a copy of OSTicket 1.7.0 locally to my desktop. Uncompressed that and traversed to the "upload" folder. Copied all those files and folders up to my "support" folder on the server.
[*]All files are assigned 644 permissions. All folders are assigned 755 permissions.
[*]Nothing new here EXCEPT the install doc "Getting Started" section wants me to change permissions on a "ost-config.php" file so it can "write" and "modify" appropriately during the initial setup and configuration of OSTicket. But this file doesn't exist??
[/LIST]

^^ There is no "ost-config.php" file located in the "include" directory. There is how ever a "ost-sampleconfig.php". <<< Ok... hmmm... why would they leave this out of the install doc I wonder. <<< Ok... the only logical assumption I can make at this point is to temporarily change permissions on the "ost-sampleconfig.php" and pray that it works. Change file permissions to 777 and saved.

Now I browse to <a rel="nofollow" target="_blank" href="http://mydomain.com/support/setup/">http://mydomain.com/support/setup/
Forbidden

You don't have permission to access /support/setup/install.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Not really sure what to do at this point as it's saying I don't have permission yet I was able to traverse into this directory just fine and see the first page that came up. I even tried setting the permissions to 777 on "install.php" in the "setup" directory and I get the same thing. First page comes up just fine but clicking "continue" brings to the page and it complains that I don't have permissions which makes no sense. <<< But then again I'm no nix permissions guru. :P

Can someone please point me in the right direction and let me know what else I need to do and possibly why the install doc references a file that doesn't exist?

Thanks for your time, very much appreciated.

Comments

  • Hi lmpc

    Yes, there was nothing wrong, initially there was no such file named ost-config.php, but the installer does include a sample file named "ost-sampleconfig.php" for you to use.

    Simply change the sample file name to "ost-config.php" and continue installlation till the end

    :)
  • Isolated and solved the issue.

    The first problem that was tripping me up was the fact that the install documentation is clearly wrong. I'm brand new to OSTicket so I take your install notes as Gospel.

    ROFL...
    If you're going to have a link to the latest OSTicket download within the same EXACT AREA that you're referencing a filename to be modified before starting the install, could you at least please give an additional explanation of what to do if the file your referencing doesn't exist. That would be a little time saver. :p

    The first thing I did was open up the "install.php" file in Cpanels code editor, it's indeed REQUIRING /include/ost-config.php. So I renamed "ost-sampleconfig.php" to what the "install.php" file is looking for.

    Jokes on us I guess. Kidding ofcourse. The thing I absolutely love about open source anything is the ability to dig around in code and archived answers on the internet.

    After renaming the file, I was still getting a permissions error page previously mentioned in the original post. Even after changing permissions on both the "ost-config.php"... and now the "install.php" < grabbing at thin air... a light turned on... ".htaccess" is the only culprit I know of (and for good reason) that does this type of blocking even when file/dir permissions are set to GOD mode.

    Sure enough, renaming the ".htaccess" in the root of my "public_html" directory to "htaccess.bak", immediately allowed me to get passed the issue. So atleast I now have the problem isolated which obviously isn't an OSTicket issue. Gotta rename this back and figure out what to edit inside the ".htaccess" file. This thing is a monster. Time to get my .htaccess learn on I guess. :eek:
  • mycelcius;39561 said:
    Hi lmpc

    Yes, there was nothing wrong, initially there was no such file named ost-config.php, but the installer does include a sample file named "ost-sampleconfig.php" for you to use.

    Simply change the sample file name to "ost-config.php" and continue installlation till the end

    :)
    Thanks mycelcius. I appreciated your posting. I got it figured out.

    The problem was a little more than unclear documentation. No worries. Seems that there's always something learned through a little frustration. :p
  • edited June 2016
    Hi all, i have the same issue, on a fresh install on centos.
    But i don't have .htaccess on my www root.

    This is the http.conf, without any change:







    #

    # DocumentRoot: The directory out of which you will serve your

    # documents. By default, all requests are taken from this directory, but

    # symbolic links and aliases may be used to point to other locations.

    #

    DocumentRoot "/var/www/html"


    #

    # Relax access to content within /var/www.

    #

    <Directory "/var/www">

        AllowOverride None

        # Allow open access:

        Require all granted

    </Directory>


    # Further relax access to the default document root:

    <Directory "/var/www/html">

        #

        # Possible values for the Options directive are "None", "All",

        # or any combination of:

        #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews

        #

        # Note that "MultiViews" must be named *explicitly* --- "Options All"

        # doesn't give it to you.

        #

        # The Options directive is both complicated and important.  Please see

        # http://httpd.apache.org/docs/2.4/mod/core.html#options

        # for more information.

        #

        Options Indexes FollowSymLinks


        #

        # AllowOverride controls what directives may be placed in .htaccess files.

        # It can be "All", "None", or any combination of the keywords:

        #   Options FileInfo AuthConfig Limit

        #

        AllowOverride None


        #

        # Controls who can get stuff from this server.

        #

        Require all granted

    </Directory>

    And this is from the log:







    [Tue Jun 28 15:07:50.309995 2016] [core:error] [pid 20430] (13)Permission denied: [client 192.168.0.176:50299] AH00035: access to /ticket/setup/install.php denied (filesystem path '/var/www/html/ticket/setup/install.php') because search permissions are missing on a component of the path

    [Tue Jun 28 15:14:20.413034 2016] [core:error] [pid 20434] (13)Permission denied: [client 192.168.0.176:50541] AH00035: access to /ticket/setup/install.php denied (filesystem path '/var/www/html/ticket/setup/install.php') because search permissions are missing on a component of the path


    Any hints?
    Thanks in advance.
  • Hint #1, this thread is from 2013.
    While you might think that you are a powerful necromancer, I assure you that your zombie is being put down with a head shot.  Closing ancient thread.  Please start your own for your issue.

    As a side note: Permission denied is your error.  Sounds like a permiossion issue to me.


This discussion has been closed.