Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Allow only users from specific from registering

hi guys, i've read a discussion about this topic but the proposed solutions did not work. I've setup osticket and now i only want to allow specific users which belong to "" to register and everything else like ", etc..." gets rejected. 

thank you in advance.


  • The only way that I can think of having this work is to not care who makes an account, but then to make a ticket filter that checked to see if the domain doesn't equal you domain, and if it doesn't match then to reject the ticket.
  • Hello @eliejtawil,

    here my solution:

    edit: \upload\include\class.validator.php

    function is_valid_email($email) {
    global $cfg;

    $domain_suffix = substr(strrchr($email, "@"), 1);
    $tld_allow = array("", "");

    if (!in_array($domain_suffix, $tld_allow)) {
    return FALSE;

    // Default to FALSE for installation
    return self::is_email($email, false, $cfg && $cfg->verifyEmailAddrs());

    and unset "Verify email address domain" in osTicket __ Admin Control Panel

    if the e-mail suffix is not or the user can't register

  • @citrixraptor thank you for your support, i will try it and give you a feedback.

    i have another issue, if i'm trying to install it on either openSUSE or CentOS i install LAMP and when i try to install the osticket php file is not parsed at all. do you have any idea what could be preventing it? (opensuse leap 42.1 and centos 7) though i tried joomla and it's working smoothly just osticket installation not working.

    i would appreciate your help.
  • edited August 2016
    Disable SELinux, and try again.  It may be blocking things from working properly.
  • Hello eliejtawil,

    >> i try to install the osticket php file is not parsed at all

    0. Check the apache log file ... errors?!

    1. Check the file permissions and the ownership of the osticket files
    is your www-data user the owner and check the permissions?
    is your mysql user ok ... check the permissions
    are the informations in your ost-config.php ok?

    2. Is the apache service and mysql service running?

    3. Is your apache directory correct .. chech the dir.conf file

    4. Delete all osticket files and delete the osticket database and start again ...
    fresh download the osticket zip

  • edited August 2016
    @ntozier i tried it with no luck

    Thank you
  • @citrixraptor apache and mysql are running as i mentioned before i ran joomla

    I will check ghe other settings thank you ill get back to you
  • edited August 2016
    @citrixraptor i was able to make it work on linux thank you. It was an issue of mysql user permission

    i just ran into another issue: I have created 2 tickets and responded and closed those tickets in more than 24 hours. I look at the dashboard the service time and response time are at 0.0 
    The ajax.reports is modified that it shows the time in hours by multiplying the average times 24 it was working before but not after a fresh reinstallation

    any help thank you in advance
Sign In or Register to comment.