Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Update from osTicket v1.10-RC.2 to RC.3

O noticed there was RC 3 tried to install it but got a blank page after upgrading. Suggestions?

Comments

  • Forgot to add this, might be of help

    Screenshot from 2016-08-30 11-49-11.png
    1551 x 876 - 361K
  • Black page means PHP error.  You would want to check your PHP error logs to see what the error was.
  • Got it!

    [30-Aug-2016 15:59:28 Europe/Lisbon] PHP Warning:  Unknown: failed to open stream: Permission denied in Unknown on line 0
    [30-Aug-2016 15:59:28 Europe/Lisbon] PHP Fatal error:  Unknown: Failed opening required '/var/www/html/suporte/index.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0
    [30-Aug-2016 15:59:31 Europe/Lisbon] PHP Warning:  Unknown: failed to open stream: Permission denied in Unknown on line 0
    [30-Aug-2016 15:59:31 Europe/Lisbon] PHP Fatal error:  Unknown: Failed opening required '/var/www/html/suporte/index.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0

  • This looks like some sort of permission issue.
    Are you running SELinux?

  • edited August 2016
    Yes, it's pre installed with centos. I have the previous rc running without any problem.
  • Try disabling it.  See if it fixes your issue.
  • edited September 2016
    Changed temporarily to permissive but got the same error.
    In case you might ask me this later, these are the folder and file rights

    f: account.php
    ---------- apache apache account.php
    f: ajax.php
    ---------- apache apache ajax.php
    f: api
    drwxr-xr-x apache apache api
    f: apps
    drwxr-xr-x apache apache apps
    f: assets
    drwxr-xr-x apache apache assets
    f: avatar.php
    ---------- apache apache avatar.php
    f: bootstrap.php
    ---------- apache apache bootstrap.php
    f: captcha.php
    ---------- apache apache captcha.php
    f: client.inc.php
    ---------- apache apache client.inc.php
    f: css
    drwxr-xr-x apache apache css
    f: file.php
    ---------- apache apache file.php
    f: images
    drwxr-xr-x apache apache images
    f: include
    drwxr-xr-x apache apache include
    f: index.php
    ---------- apache apache index.php
    f: js
    drwxr-xr-x apache apache js
    f: kb
    drwxr-xr-x apache apache kb
    f: login.php
    ---------- apache apache login.php
    f: logo.php
    ---------- apache apache logo.php
    f: logout.php
    ---------- apache apache logout.php
    f: main.inc.php
    ---------- apache apache main.inc.php
    f: manage.php
    ---------- apache apache manage.php
    f: offline.php
    ---------- apache apache offline.php
    f: open.php
    ---------- apache apache open.php
    f: pages
    drwxr-xr-x apache apache pages
    f: php_errors.log
    -rw-r--r-- apache apache php_errors.log
    f: profile.php
    ---------- apache apache profile.php
    f: pwreset.php
    ---------- apache apache pwreset.php
    f: scp
    drwxr-xr-x apache apache scp
    f: secure.inc.php
    ---------- apache apache secure.inc.php
    f: setup
    drwxr-xr-x apache apache setup
    f: tickets.php
    ---------- apache apache tickets.php
    f: view.php
    ---------- apache apache view.php
    f: web.config
    ---------- apache apache web.config

  • Hi
    Any other ideas? :)
  • I have no idea why your web server is telling you Permission denied.  It has to be your Apache config, your php config, a firewall/security software/module, or actual permissions.  It does not appear to be permissions at the file system level (although I don't know if your web server is running as the apache user).
  • edited September 2016
    Hi
    Yes it is running as apache user.
    Do you know of any network rights that changed from any of the previous versions (including rc 2) to 3 that could be responsible?
  • My understanding was that no features were added, and bugs were just squashed.
  • "squashed" that sounds messy :)
  • I've decided to do something "radical" that worked. Got the .tar from teh annoucement in github and... it worked!!!
    Guess it must be something related with the package.
    Just a heads up.
  • Nice!  So to be clear you are saying that the download from osticket.com/download has an issue?
    If so I need to tell the devs asap.
  • edited September 2016
    Yes indeed, but now I get another problem. "This action requires a lock. Please try again" I get this error no matter what ticket I open. Regarding contact the devs, what's the proper way?
    Found  this error in the logs

     Invalid CSRF Token __CSRFToken__

    Invalid CSRF token [7a1fe2f60fe24032973754282d3a9ee2fac6ce5b] on http://10.17.224.239/suporte/scp/login.php

  • Q: Regarding contact the devs, what's the proper way?
    A: You can use github and post an issue report at https://github.com/osTicket/osTicket/issues/new
    or you can use professional support at http://osticket.com/support

    There is no guarantee that they will answer you.
  • I have problems after upgrading 1.10.rc2 to 1.10.rc3 with KB
    users can read it, but admins can't manage...
    in logs there are php errors:

    2016/09/13 13:58:57 [error] 19499#19499: *3013 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to a member function sort() on array in /var/www/helpdesk/docs/include/staff/faq-categories.inc.php:147
    Stack trace:
    #0 /var/www/helpdesk/docs/scp/kb.php(31): require_once()
    #1 {main}
      thrown in /var/www/helpdesk/docs/include/staff/faq-categories.inc.php on line 147" while reading upstream, request: "GET /scp/kb.php?_pjax=%23pjax-container HTTP/2.0"
    2016/09/13 14:05:51 [error] 28726#28726: *3098 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to a member function sort() on array in /var/www/helpdesk/docs/include/staff/faq-categories.inc.php:147
    Stack trace:
    #0 /var/www/helpdesk/docs/scp/kb.php(31): require_once()
    #1 {main}
      thrown in /var/www/helpdesk/docs/include/staff/faq-categories.inc.php on line 147" while reading upstream, request: "GET /scp/kb.php HTTP/2.0"
  • @HighTower please do not hijack other users threads.  If you have an issue please start your own thread.

    What you need is here: https://github.com/osTicket/osTicket/issues/3147

  • ntozier, ok, I'll do it, as described solution solved problem only partly... faq categories appeared, but php error still present...
Sign In or Register to comment.