Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Warning: Failed to connect to email server at localhost...


This is strange, I am running osTicket 1.9.14 on Server 2012 R2, IIS 8.5, PHP 5.6.x. When trying to test email genration I get the error
Warning: Failed to connect to email server at localhost Port 26 . Emails DO get sent but php.ini has the smtp localhost commented out.
ANd mail.php does not have an ini_set() .

Where would this be getting picked up?



  • Sounds like you set something some where to use port 26. (which is not a port I have ever used)
    I presume that if it tried to connect to localhost post 26 that there is no mail server on local host anwsering on that port.
  • I mistyped, port 25. But I get the idea.
  • edited September 2016


    There is no SMTP on the osTicket machine. If SMTP=localhost and smtp_port are commented out where is it picking up the fact it wants to get to localhost? Essentially we are using a remote SMTP server (I don't manage). Whether I do this with a browser on the osTicket box or my workstation it gives this error.

    I ASSUME there should be a config file somewhere unless this info is stored in the database. Mail is configured in the interface for osTicket in "Emails". And the page for this email matches the old server which does not get this error.

  • Your SMTP server is configured in your PHP.ini.
    You can also over ride that with setting the server information in the Admin panel -> Email.
  • Okay SMTP is working just fine, emailing to all people it should. I just don't know where it is picking up the error, is it possible there is a code error? As mentioned I have mail commented out of the php.ini and have SMTP set up in the interface itself.

    I got rid of display_errors and I have a clean page. Funny thing is NOW I have an php_errors.log . Maybe displaying it on the page kicked it in the pants and got the error log going?

    But bottom line is I am good...

Sign In or Register to comment.