Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Linked in email does not work


We seem to be encountering an issue with our OS Ticket install in that we quite often include web links in the responses we send to our clients. If you are click the link while logged into the client interface of OS Ticket then the link works find and the client is re-directed to the correct page.

However the client also recieves an email with our repsonse in it. When they click on the same link in the email their browser responds with server not found. When looking at the link in the email send to the customer rather than being the link we put in the link instead appears to be prefix with additional information.

For example, we enter as a link in the response, in the email the client receives the link has become "l.php?" (copied directly from href tag in the source of the email)

From what I can see it looks like the link is expected to be processed against a php script on local to the server where OS Ticket is hosted, which is fine when the client is looking at response while logged into our instance of OS Ticket. But when they are looking at it in the email they have received surely this needs to be the full path to the php file otherwise it will never be able to resolve the address.

OT Ticket version and Server information:

Server Information
osTicket Version v1.9.0-3-gae5e138 (ae5e138)
Server Software Microsoft-IIS/7.5
PHP Version 5.5.11
MySQL Version 5.5.38
PHP Extensions

gdlib Used for image manipulation and PDF printing

imap Used for email fetching


xml-dom Used for HTML email processing

json Improves performance creating and processing JSON

gettext Improves performance for non US-English configurations

mbstring Highly recommended for non western european language content


  • Out of curiosity how are you adding the link to the ticket:
    copy and paste?
    typing it?
    or using the link button in the editor?

    I feel like this is a bug with the version that you are running and should probably upgrade from 1.9.0 to 1.9.3.
  • Hi,

    We've tried a number of ways of putting the link into the response.

    We use a canned response with a link in, I've tried using the link and unlink buttons to add the link, I've also switched to code view and typed the link in directly using html tags. I've tried copy and pasting the link in directly and typing the link in. Doesn't seem to make any difference which way I add it.

    I'll try upgrading to 1.9.3 this weekend and see what difference this makes.
  • My brain is telling me that 1.9.0 had an issue with this, and that its since been fixed.  Either way please what happens. :)
  • Looks like I am having this issue on v1.9.14 (8b927a0) . Anyone else having the same problem??? 
Sign In or Register to comment.