Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cannot create users or organizations

Server Information
osTicket Version: v1.10 (901e5ea)
Web Server Software: Apache/2.4.18 (Ubuntu)
MySQL Version: 5.7.16
PHP Version: 7.0.8-0ubuntu0.16.04.3

This is fresh installation on a VPS, and was tested on a local server with the same results. I'm not terribly familiar with osTicket, but it looks like it is not bringing up any of the forms to allow input. I experience it on the client side for creating an account. Only enterable options are for the password. Also experience it on the admin side when trying to add a user or organization.

No errors reported in the apache log. Tested in Firefox, Chrome, and IE all with the same results.

I'm hoping that I've just missed a setting, but I've ran out of places to look. Any assistance is greatly appreciated.

Some screenshots attached




  • This was reported on github also but for develop (a pre-release version that changes pretty much daily).

    Here is the thread in case you want to add your findings to it.

    I've messaged the devs to take a look at this.  I do not see this on my test install, and I'm not running php7. Can you downgrade php to 5.6 and see if you still get this behavior?
  • I added a comment to the github post. Same results with php 5.6
  • Thanks!  I was really hoping that it was a PHP bug.
    Are you running anything like SELinux, mod_security, suhosin?
  • ntozier-

    It's a default Ubuntu 16.04.1 server install with apache2, mysql and php. Nothing else added.

    I just did the exact installation on Debian 8.6 and the input forms are visible and working as expected.

    Debian info
    Web Server Software: Apache/2.4.10 (Debian)
    MySQL Version: 5.5.53
    PHP Version: 5.6.27-0+deb8u1
  • So then it stands to reason that Ubuntu is installing something else, or has a configuration difference that is preventing it from working.
  • I would agree. I'm fine running on Debian and will just leave it alone now. I do still have the Ubuntu instance running so if there's any additional info you need/want I can supply it.

  • Tried with vanilla Ubuntu Server 14.04 VM running PHP5: Works fine
    Then tried with a vanilla VM running Ubuntu Server 16.04 with PHP7 and it's not working.
    Certainly has the feel of an Ubuntu PHP7 "Configuration Enhancement".

    Note that the "PHP Warning:  Declaration of AssignmentForm::render($options) should be
    compatible with Form::render($staff = true, $title = false, $options =
    Array) in /var/www/html/osTicket/include/class.forms.php on line 4150" error is also present.
Sign In or Register to comment.