Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

AD/LDAP-integration not working with 1.10

I upgraded to v1.10 today, but it seems that I can't login to scp using my AD credentials.

Luckily I remembered my local credentials and I was able to login.

There is an updated plugin from Nov. 2016 to download. Can I just download this at place it on top of the old one - and will the settings from the old plugin be kept?

Regards, Lars.

Comments

  • You will have to download the new one and delete the one in the system and then add the new one with the settings. So write down your settings if needed :-)
  • You should also be aware that there is a bug in the current version (1.10) with search if the auth-ldap plugin is enabled.  I have posted a fix for it here: https://github.com/osTicket/osTicket/pull/3456
  • Hmm... search in which way. LDAP Search Base?

    Think is I have now downloaded the new one - installed it and typed in the same settings as the old one.

    It tells me:
    Bind failed: Invalid credentials: Unable to bind to server xxx

    Is this the bug you are describing? I am pretty sure the creds. are correct.

    Regards, Lars.
  • Q:  LDAP Search Base?
    A: No.

    Re: Invalid credentials: Unable to bind to server 
    Then you are using invalid credentials.

    Q: Is this the bug you are describing?
    A: No.

    Have you downloaded the new version of the plugin from here?: osticket/com/download
    Have you installed the new version?
    Have you configured it?
    Have you enabled it?
    Have you also gone and done the edit required to make use search work that I posted?
  • Yeah, it would be obvious that the credentials are invalid, but I am pretty sure they are ok. I will double check in a moment.

    Is the search fix important for the AD-login to work? If not I will leave it a for a while.

    Regards, Lars.
  • Credentials checked... they are ok. They include special characters. Is this an issue? It is the same login as with the prior OSticket version.

    Regards, Lars.
  • Hi again.

    Could you please elaborate a bit more on the bug you are referring to. We are talking about the:

    Search User:
    Bind DN (distinguished name) to bind to the LDAP server as in order to perform searches

    Or maybe I am lost?
  • The bug is: When you click on new ticket... you cannot search for users at all.
Sign In or Register to comment.