Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Users Not Authenticating

I have my system set to private, so agents must register users.  When registering users, I'm given the option to authenticate using "any available backend", and I would prefer this to be linked with AD so that users don't have to have separate passwords for the helpdesk system and their normal domain accounts.  I have the LDAP plug installed and enabled.  Upon registering, users set a PW, and that's the PW they have to use, not their normal account PW.  I'd really like for the users to be able to use the same PW as their normal account, like agents are able to.

Any ideas?
Tagged:

Comments

  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.
  • edited January 10
    Server Information
    osTicket Version     v1.9.5.1 (1faad22)
    Web Server Software     Microsoft-IIS/7.5
    MySQL Version     5.6.17
    PHP Version     5.3.28
    PHP Extensions
    gdlib     Used for image manipulation and PDF printing
    imap     Used for email fetching
    xml     XML API
    xml-dom     Used for HTML email processing
    json     Improves performance creating and processing JSON
    mbstring     Highly recommended for non western european language content
    phar     Highly recommended for plugins and language packs
    fileinfo     Used to detect file types for uploads
    PHP Settings
    cgi.fix_pathinfo     "1" is recommended if AJAX is not working
    date.timezone     America/Tegucigalpa


    STAFF side, can log in with AD credentials, no issues.  Cannot log in with AD credentials on USER side
  • What version of the ldap plugin are you running?
    I dont know if the current version has been tested with such an old version of osTicket.
  • According to the plugin.php, it's auth-ldap v0.4

    <?php

    return array(
        'id' =>             'auth:ldap', # notrans
        'version' =>        '0.4',
        'name' =>           'LDAP Authentication and Lookup',
        'author' =>         'Jared Hancock',
        'description' =>    'Provides a configurable authentication backend
            which works against Microsoft Active Directory and OpenLdap
            servers',
        'url' =>            'http://www.osticket.com/plugins/auth/ldap',
        'plugin' =>         'authentication.php:LdapAuthPlugin'
    );

    ?>
  • Have you enabled User logins to use LDAP?
    Manage -> Plugins -> LDAP Authentication and Lookup -> tick Client Authentication


  • that does not appear to be an option in this version.  guess i'll have to update.
Sign In or Register to comment.