Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Duplicate Tickets - IMAP / osTickets v1.9.14

Hi,

I have osTickets v1.9.14. We have been battling with duplicate tickets for some time now. We have several departments, each with their own Gmail account to retrieve emails/tickets via IMAP. What will happen is a user sends in a ticket and osTicket seems to pull the email and create two tickets. Same email, same subject, same sender but different ticket ID's. See images for settings and an example of a duplicate ticket. How can I fix this?


imageimageimageimage

Comments

  • I am curious, has this recently started happening? Did anything change around the same time that this happened?
  • edited January 31
    It's very random and has happened since the beginning. I haven't been able to pinpoint the cause though. It's an EC2 instance on AWS with an AWS RDS (MySQL) instance for the DB. I have already rebooted everything and made sure that both instances aren't being taxed.
  • um, if it's happened since the beginning, why wait until now when you are actively using the ticketing system? Also, any reason you have not updated to the latest version?

    @Sperrow, any idea why duplication would be caused?
  • edited January 31
    Well, it hasn't been service affecting, more of an annoyance. We've had this set up for about 3 weeks now so I wouldn't say I waited that much time considering I'm 1 guy managing a thousand other things. Any help would greatly be appreciated. 

    I plan to upgrade to the latest version overnight but highly doubt that will fix this issue as it's not a specific fixed item in the release notes.
  • Maybe you collect emails too frequently via autocron and a cron job? I would recommend not using autocron (especially both autocron and cron together) and the cron job should only collect every 3 minutes or a higher value. Fetching emails too often in a short time frame is not so good. Adjusting "Emails Per Fetch" could also be helpful with this issue.. 
  • edited January 31
    So I should deselect "Fetch on auto-cron" and let the cron job do the fetching? What should I set the Fetch Frequency and Emails per fetch values to?
  • Also, when I deselect "Fetch on auto-cron", no emails are pulled. Is my cron job set up incorrectly? When I do a "which php" on ubuntu it gives me /usr/bin/php as the path so thats what I used in the cronjob with nobody as the user.
  • @Panda, did you have a look at the wiki and follow the steps there?
    http://osticket.com/wiki/Email_settings
  • Yes I did.
  • Hello, what @mfelber said is quite possible about auto-cron, because Auto-cron: "Enables periodic email fetching using an internal task manager triggered by Agents' activity."

    It might be that your cron, which you have set up, e.g., to fetch e-mail every minute or less fetches the mail at the same time as auto-cron triggers via your or someones activity and if you have a lot of agents, it makes it even more possible.

    Try to disable auto-cron and see if that helps, you do not really need to use auto-cron if you have cron script running every minute or so, it won't make it a lot faster :)

  • @Sperrow thank you the information. However, when i disable auto-cron I don't receive emails. Is my cron job not set up correctly?
  • Would seem so, could you please run the cron manually from command line:
    /usr/bin/php /path/to/osticket/upload/api/cron.php

    It should show you errors if you have them that is or the errors should be in your web servers logs in /var/log/whateveritisforubuntu

    Can you confirm the frequency of the cron job you are running in background too?
  • @sperrow When i run that manually from the command line it gives no errors but also does not pull any emails. I have it set to */3 which should be every 3 minutes.
  • edited February 2
    @sperrow Nvm, this has been resolved. I enabled debug level logs on osTicket and could see the error messages now. It was stating that it could not find sendmail when i ran the cron manually. I installed sendmail and restart apache2 services and it is now working. So, to conclude, I disabled auto-cron and only have cron job running which should resolve the duplicate tickets issue. Ty all for your help with this!
This discussion has been closed.