Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

authentication failure [SMTP

Please helpme:

authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]
I'm trying out multiple email servers around the world.
None of the SMTP works.
About osTicket Installation
Server InfoVersion of osTicket v1.10 (901e5ea) - UpdatedApache Web Server SoftwareVersion of MySQL 5.6.35PHP version 7.0.15

Comments

  • I would recommend that you downgrade to PHP 5.6 and try again.  A lot of people have reported wonky errors with PHP 7+.  Additionally I trust that you granted your user connection rights at the mail server? 
  • Same mistake.

    I use cPanel in the latest version and Centos

    I already changed my domain to PHP 5.6

    But the error persists.

    I have OSTICKET installed on another server, but with these settings:

    Version of osTicket v1.9.14 (8b927a0) Upgrade - v1.9.15 is available

    Web Server Software Apache / 2.2.27 (Unix) mod_ssl / 2.2.27 OpenSSL / 1.0.1e-fips

    Version of MySQL 10.1.20

    PHP 5.3.29 version

    In this old version of OSTICKET my corporate email can send emails.

    Only in the newer OSTICKET version is this error occurring.

    I have tried to install the new version on the other server, but when I send the files to the server, the page does not open, it seems that in PHP 5.3 the new version of OSTICKET does not work.
  • Correct.  The new version does not work under PHP 5.3.  

    "installed on another server"
    Did you grant the new server access to connect to your mail server?
  • Restart my cPanel CentOS Server!
    Now it's with PHP 5.6

    Now the error has changed:

    Authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)]
  • I have another server with CentOS 7 installed and manually installed Apache, PHP 5.3, phpmyadmin and MySQL.

    On this server, which is installed OSTICKET v1.9.14 (8b927a0), my email works correctly.

    But when I try to use it on my other server but with cPanel and PHP 5.6, the same email does not work at all.

    Understood ?
  • Q: Additionally I trust that you granted your user connection rights at the mail server? 
    A: ?

    Q: Did you grant the new server access to connect to your mail server?
    A: ?


  • I did not understand your questions.

    My e-mail server is a Microsoft Exchange Server 2016, corporate e-mail.

    This email is working on the server with the old OSTICKET version.

    Only in this new OSTICKET version does it not work.
  • From what I researched on the internet, the error is in the SMTP.php file of OSTICKET in this new version.

    Error negotiating TLS.
  • Well CentOS ships with SELinux which doesn't allow certain things by default... So I would start by checking that.

    Then I would go to the Exchange server and make sure that there was a transport rule that allowed the new webserver to connect and talk to the mail server.
  • Default SELinux is disabled in CentOS when WHM / Cpanel is installed.

    And on my mail server, Exchange, you do not have to create / edit any rules.

    I just put the email account data on OSTICKET and it works fine.

    But in this new version, neither my Exchange body mail, Yahoo email, GMail, nor Hotmail does not work.

    Everyone experiences the same TLS negotiation error.
  • Thank you very much.

    Reading the comments I saw that a simple downgrade to version 5.5 of PHP solves the problem.

    I hope OSTICKET support will correct this soon, because this version of PHP does not run many of my sites.

    I'll have to put it in a separate domain.

    But at least he decided.

    Thank you.
  • edited February 6
    downgrading seems easiest, but if you wanted to keep same PHP version you could have disabled peer name verification. I am no coder but I am reading the link ntozier posted and saw that, just wanted to provide it just in case it helps.

    https://github.com/osTicket/osTicket/commit/4f68aeb3fd746a18c598689b8b428db49faa7613
  • i got an (SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready) on CPanel..  what i did is copy the SMTP of OSticket version 1.10.. It works for me..
  • Hello,

    The problem has happened again.
    The system has stopped sending emails again.

    Version of osTicket v1.10 (901e5ea) - Updated
    Apache Web Server Software
    Version of MySQL 5.6.35
    PHP version 5.6.30

    Sending E-mail via SMTP
    Authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]

    I'm getting sick of this system, it's always been very good, but now you can give it up.
  • @welltecnologia

    authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]

    This generally means that your username/password is incorrect. Or at least that the username/password that the server is receiving is being reported as being incorrect.
  • Hello,

    I understood that too.
    But it is not.

    As I said before, I have another server with OsTicket installed on the version:

    Server Info
    Version of osTicket v1.9.14 (8b927a0) Upgrade - v1.9.15 is available
    Web Server Software Apache / 2.2.27 (Unix) mod_ssl / 2.2.27 OpenSSL / 1.0.1e-fips
    Version of MySQL 10.1.20
    PHP 5.3.29 version

    This server is using the same e-mail account and is running smoothly.

    However, if you install the new version of OSticket, then the email stops working.

    That old TLS problem that's happening in this new version.

    The new version of OSTicket is installed on my server with cPanel.

    I've downgraded PHP to 5.5 and 5.6 and it also does not work anymore, the strange thing is that it worked before, but now it has stopped.
  • Hi Kevin,

    Another error:

    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)]
    Dont working.....
  • Hello,

    Look, I did what I was doing on the site inside my WHM Cpanel.

    As I saw it still gave error, I downgraded from my PHP to version 5.5 and now it worked!

    Thank you very much.
  • So back on Feb 6th when I said:


    Did you read the link? Or do the downgrade as suggested in the thread..  or try the patch in the thread provided by Ray?
  • Hello,

    Yes, I read.
    But it only worked for three days.
    Then he got back to sending emails.

    Today I made the configuration inside my WHM Cpanel and downgraded to PHP 5.5

    Now I put it into production and I'll see if the error will come back.
  • I'll let the devs know that their fix worked for 3 days.
    And you ultimately had to downgrade to 5.5
  • But it was not just that.

    It has a function that I had to change in my WHM / cPanel.
  • edited February 17
    Do you have a test environment that is getting this issue with PHP 5.6 and osTicket 1.10?
    If so try something for me to see if your issue goes away (I am unable to replicate this error):

    1.) Go to {osTicket directory}/include/pear/Net/SMTP.php line 173 and change this line:
    'ssl' => array('verify_peer_name' => false)
    to this
    'ssl' => array('verify_peer' => false, 'verify_peer_name' => false)

    2.)Go to {osTicket directory}/include/pear/Mail/smtp.php line 141 and change this line:
    $timeout = null;
    to this
    $timeout = 60;

    Hit us back with the results!
  • I do not need to do this anymore.

    It is already running.

    I just downgraded to PHP 5.5 and made these modifications in my WHM / cPanel:

    The cpanel server was configured only for root user and on the other user. Hence whenever the email was being sent via PHP, smtp would redirect to the local server.

    To verify and rectify the issue please follow:
    "SMTP to root, exim, and mailman (FKA SMTP Tweak)" under WHM> Server Configuration> Tweak Settings> Mail. Enabling this feature will redirect outgoing SMTP connections to the local mail server. Root, exim, and mailman are still allowed to make direct connections.
  • I know you have fixed it by downgrading to PHP 5.5 but just to let you know I was unable to downgrade the PHP version as it is shared by other applications. I finally managed to fix it by following one of the comment here: https://github.com/osTicket/osTicket/issues/2628 (Axwell). 

    The steps:

    Download the file from

    https://pear.php.net/package/Net_SMTP/download
    http://pear.php.net/package/Net_Socket/download

    Replace SMTP.php and Socket.php from "include/pear/Net/" with the ones from the downloaded archives.

    Works for me!

  • edited March 7
    @amsut you are amazing, it's always appreciated when folks chime in with resolutions :)

  • Are you sure that replacing these 2 files 


    will fix this error:

    authentication failure [SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)]


  • I solved my problem, I change the both files STMP and SOCKET and also change the smtp port number to 465

    I am working with windows server
Sign In or Register to comment.