Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Problem with email setup

I am very new here and start playing with selfhosted OsTicket today. During email setup, I am having problem in "Sending Email via SMTP". Below is my setup:
Hostname: rhw9009.star1.nesdis.noaa.gov
Port number: 587

But I get the message "Failed to connect to rhs9009.star1.nesdis.noaa.gov:587 [SMTP: Failed to connect socket: Permission denied (code: -1, esponse: )]".

I also tried port 25, and got the same error message.

FYI, I have another ticketing tool installed on the same machine, and I have verified the above SMTP server and port 25 work successfully on that tool.

Any help is apprieciated.

Below is the OsTicket that I installed:
osTicket Version     v1.9.2 (4827655)
Server Software     Apache/2.2.15 (CentOS)
PHP Version     5.3.3
MySQL Version     5.1.73
PHP Extensions   
    gdlib     Used for image manipulation and PDF printing
    imap     Used for email fetching
    xml     XML API
    xml-dom     Used for HTML email processing
    json     Improves performance creating and processing JSON
    gettext     Improves performance for non US-English configurations
    mbstring     Highly recommended for non western european language content
    phar     Highly recommended for plugins and language packs
PHP Settings   
    cgi.fix_pathinfo =     "1" is recommended if AJAX is not working
Database Usage
Database Space Used     0.26 MiB
Database Space for Attachments     0.01 MiB

Thank you in advance,
Jewel

Comments

  • Permission denied.  Sounds like a firewall is preventing the connection.  Since your running CentOS my guess would be SELinux as the culprit. 

    I'm not sure why you would install 1.9.2 though, its really old at this point.
  • I scratched my head with a similar issue and found SELinux to be preventing connections. Once I followed the recommended commands, I was up and running.


Sign In or Register to comment.