Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Inserting screenshots only works half of the times

Hi, 

Inserting screenshots into the ticket response via the WYSIWYG editor only works half of the time. I do NOT have a DB error message (which I seen some others have), but most of the times nothing happens when we try to insert a screenshot into the middle of a response. We realized that this feature is working well if you paste the image into a new (empty) response, but once something have been written or a canned response have been selected the pasting option only works once out of 10 times. 

After pasting the image a small icon spinning somewhere in a middle of a text. (This small icon is randomly located, e.g. on the attached screenshot, I tried to insert the image right above the "Please contact us" part.)

I tried inserting via the image insert icon from the editor buttons, but it does not work either. 

Any idea what could be the issue? Are others experiencing the same? 

Our system/environment is: 

Client: Win 10 / most recent Chrome browser

Server:
DB: 
MySQL: 5.6.27. (AWS RDS)

Web: 
Red Hat Enterprise Linux Server release 6.9 (Santiago) (AWS EC2)
PHP: 5.6.30.

Comments

  • Actually, I have DB error in the log which probably belong to this:

     DB Error #1062

    [INSERT INTO `ost_attachment` SET `file_id` = 34659, `type` = 'D', `object_id` = 516532, `name` = 'screenshot-5L2f'] Duplicate entry '516532-34659-D' for key 'file-type'

    ---- Backtrace ----
    #0 (root)/include/mysqli.php(204): osTicket->logDBError('DB Error #1062', '[INSERT INTO `o...')
    #1 (root)/include/class.orm.php(3133): db_query('INSERT INTO `os...', true, true)
    #2 (root)/include/class.orm.php(597): MySqlExecutor->execute()
    #3 (root)/include/class.attachment.php(161): VerySimpleModel->save()
    #4 (root)/include/ajax.draft.php(101): GenericAttachments->upload(Array)
    #5 (root)/include/ajax.draft.php(300): DraftAjaxAPI->_uploadInlineImage(Object(Draft))
    #6 [internal function]: DraftAjaxAPI->uploadInlineImage('516532')
    #7 (root)/include/class.dispatcher.php(145): call_user_func_array(Array, Array)
    #8 (root)/include/class.dispatcher.php(38): UrlMatcher->dispatch('516532/attach', Array)
    #9 (root)/include/class.dispatcher.php(120): Dispatcher->resolve('516532/attach', Array)
    #10 (root)/include/class.dispatcher.php(38): UrlMatcher->dispatch('/draft/516532/a...', NULL)
    #11 (root)/scp/ajax.php(262): Dispatcher->resolve('/draft/516532/a...')
    #12 {main}


    Log Date: Mon, Apr 3 2017 4:00pm IP Address: 65.50.240.242
  • edited April 4
    I have never had a problem inserting an image into a ticket clicking the image button on the editor bar.
    I have ALWAYS had issues dragging and dropping images into the editor.
    I believe that there is several issue reports for the latter at github.
  • edited April 6
    Are you using Firefox @tiszavolgyi?

    I never had problems with copying & pasting images into the editor until the most recent Firefox Updates. It worked fine for me in Firefox 48.0.2, after i updated to 51.0 i had the same issues. With Firefox 52 i can not paste ANY images into the editor.

    So i changed back to 48.0.2.

    EDIT: I just saw you are using Chrome, i will check what version we used for the test.

  • Thanks a lot Anarki!

    Our customer support reps use the most recent Chrome and Firefox version and I cannot roll back unfortunately. 
Sign In or Register to comment.