Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

v1.9.12 to v1.10 upgrade issue error 500

Hello:

Looking to see if anyone has any suggestions.

After uploading v1.10 files to server, I get error 500 when accessing osTicket.  Log files show nothing other than 500 errors:

- - [16/Apr/2017:17:03:43 -0400] "GET /support/ HTTP/1.1" 500 5 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36"

I think this may have to do with the fact that the v1.9.12 version was moved from HTTP to HTTPS. V1.9.12 worked fine in HTTPS without any changes other than changing Helpdesk URL Setting to HTTPS path.  If I restore back to the v1.9.12 files, everything works fine again.

This is on a shared host server.
MySQL Version 5.5.53
PHP Version 5.3.29

File permissions are set correctly, and I did a recursive rewrite of permissions and tried again, still same error accessing osTicket.

Turning on Display Errors was also of no help, still error 500 trying to access osTicket.

If anyone has any ideas or suggestions, please let me know.

Thank you for your time!

Comments

  • Your problem is this: "PHP Version 5.3.29"
    Please upgrade your PHP to 5.6.
  • Requirements on http://osticket.com/faq say PHP 5.3+ so I meet the requirements as stated on this page.

    If v1.10 requires PHP 5.6 then the FAQ page needs to be updated to correctly reflect this requirement.

    Unfortunately, since I am on a shared host, I can not upgrade PHP.

    Thank you.
  • That page is not correct.
Sign In or Register to comment.