Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Mailer error

I did setup sending emails through our GSuite account but I am getting Mailer Errors

Unable to email via SMTP:ssl:// [] Failed to set sender: [SMTP: Invalid response code received from server (code: 550, response: 5.7.1 Invalid credentials for relay []. The IP address you've 5.7.1 registered in your G Suite SMTP Relay service doesn't match domain of 5.7.1 the account this email is being sent from. If you are trying to relay 5.7.1 mail from a domain that isn't registered under your G Suite account 5.7.1 or has empty envelope-from, you must configure your mail server 5.7.1 either to use SMTP AUTH to identify the sending domain or to present 5.7.1 one of your domain names in the HELO or EHLO command. For more 5.7.1 information, please visit 5.7.1 c207sm541732wmd.0 - gsmtp)]

The IP address you registered in the G Suite SMTP relay service setting doesn’t match domain of the account this email is being sent from. If you are trying to relay mail from a domain that isn’t registered in your Googles Apps account, you must configure your mail server either to use SMTP AUTH to identify the sending domain or to present one of your domain names in the HELO or EHLO command. See SMTP Relay service setting for more information.

GSuite SMTP relay is configured to only accept mail from the specified IP addresses 87.XX.235.184
OSTicket is hosted on server IP 87.XX.235.184 available on
From email setup in OSTicket is

How can I solve this? Shall I use

Thank you in advance,


  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.
  • Shall I understand that you require my nginx server logs in order to help with that issue? I'm not quite sure it's at all related... Please confirm,
  • NGINX is not supported by OSTicket, maybe that's why? Could you use Apache or no? 
  • @LeoG Yes and No. Errors from your various logs that are and might be related is a piece of it.  I require more information about your setup to decide if I can be of any assistance to you. Such as: Names and versions of pertinent software; applicable settings in osTicket, etc.
  • Names and versions of pertinent software
    > Gsuite > the cloud enterprise soft from Google. Link to documentation in the original message
    > OSTicket > 1.10 non modified
    > Hosting > OVH Perso (no idea if NGINX or Apache)

    applicable settings in osTicket, etc.
    > Alerts are sent on various events and triggers are working
  • Well you did state "Shall I understand that you require my nginx server logs in order to help with that issue? " - so what made you think you have NGINX in the first place?
  • You could understand it this way ;)

    - It's impossible to SSH on a OVH Perso
    - I can see in the phpinfo:
    SAPI Modules
    Apache 2.0 HandlerIan Holsman, Justin Erenkrantz (based on Apache 2.0 Filter code)

    > I was convinced of getting a NGINX error on another website I have on this hosting. I was probably wrong.

    Is there a way to "make sure" which is used on OVHPerso?

  • How if you setup mail server like postfix in your server ? Any people already try before ?
  • I do not have SSH access nor ability to install software on this server.

    My original question here is: how to make GSuite SMTP work with OSTicket? It has been working for us in the past. we'd like it back.

    Anybody has experience with this?
  • I found the solution for anybody who come accross such problem (550, "5.7.1", Invalid credentials for relay. for Google GSuite)

    1. Log into the GSuite admin console and head to the email report ( in order to check email logs

    2. Message details
    Message ID:
    May 2, 2017, 11:40
    Error details:
    The connecting IP address 91.XXX.248.235 might not have been included in the list of allowed IP addresses in your SMTP relay settings. Otherwise, if TLS encrytion was enabled, there may have been an issue negotiating the encrypted communication.
    For more details, visit SMTP relay service setting.
    3. Log in back to GSuite admin console > SMTP relay, add the IP above (91.XXX.248.235) > working!

    Now why OVH displays that my server IP is on 87.XX.235.184 (and it is, I have a A record on this!)
    and my SMTP see email requests from 91.XXX.248.235?
    No idea. If anybody can jump in with explanations? My guess is that this is a way for OVH to optimise their infrastructure? maybe...

    Anyway, problem solved. Thanks.
  • edited May 2017
    Thank you for the response on how to do this.

    What is OHV stand for? Is this a shared hosting provider? 

    people can have different SMTP servers that are not the same as your host server.

  • Hi there!

    OVH is a big player in hosting in EU > I didn't even bother mentioning that. My bad :S

    They are the french equivalent of 1and1 or Strato which are 2 big DE players I believe.

    Having tried them all, I wouldn't recommend none of them and rather vouch for AWS but it happens that my company has historically servers at OVH...

    In my case I believe my SMTP server is GSuite available at ssl://
    and my web server is OVH available at 87.XX.235.184

    Now why GSuite sees incoming requests from 91.XXX.248.235?
    I'd like to understand that, but it's maybe not the right place to speak about this ;)

    Thanks a lot for your help anyway!
  • I may just message you privately since this doesn't seem to be an OSTicket issue. 

    Is your OSTicket working as it should and you have no further issues on the subject in thread? if so I will close this thread and continue privately with you in a DM. 
  • Awesome! Thanks for posting your solution, @LeoG!
  • Looks like your account is trying to send/login directly via the relay, when you should have an SMTP server relaying via the Google relay.
Sign In or Register to comment.