Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cursor looses focus when using backspace



  • edited February 2017
    No I decided to wait un til 1.10 and tried to have a look when it still occured after update.
    Tried 1 solution in the previous version, the first solution, change autosave value. Did not help.
    But in the 1.10 version it looks different in the redactor-osticket.js so I was afraid to mess things up. I'm no php coder so I can read a bit php and I can do copy and paste stuff.

    However it was told it was fixed in 1.10, so why should one try fixed if it was stated as fixed?
    I would like to try a fix, but does it really mean in spite of what mentioned before that this issue is indeed not fixed in 1.10?
  • I dont run 1.10 in procduction so I have no idea if it is still an issue.  There have been a lack of posts about it though
  • I'm sorry. I wasn't sure anymore so I checked again to be 100% sure.

    I did change the line:

    // this.$toolbar.append(this.$draft_saved);

    as suggested on the previous page as a solution because I still had problems in 1.10.
    So it looks as if it's still not fixed in 1.10.

    Indeed there have been a lack of posts about this, so I wonder if anybody else is still having issues with it or if they are also just use the suggested fix.
  • We have this problem, more frequently in Firefox than Chrome. We have accepted it as a nuisance since it does not keep us from getting things done.

    Admittedly we have also not attempted any of the fixes. 

  • I ditched FireFox last year sometime and predominantly run Chrome now.
  • I don't like Chrome. I'll keep using Firefox.
  • Dear osTicket team - this issue drives us nuts.. We are typing and hit backspace and all of a sudden we are deleting words 3 lines down..

    I am running 1.1 and while osTicket is great - its getting to the point where we dont really want to use it any more.

    If there is going to be an official fix, then good, but if its not planned, can I suggest it is fixed?  It will be affecting everybody to one degree or another.

    I am happy to try any suggestions to see if it works.. -We really would like to keep autosave..


    p.s. - has the timekeeping addon been updated to work with 1.1 ?  It was brilliant and we lost it upgrading (I should have thought that one though) but 1.1 is so much better we now dont want to go back..!!
  • Xmanflash: It looks like the suggestion I mentioned above, to put // in front of that line, seem to fix the problem.
    Ofcourse this is a workaround and the real issue should be fixed.

    Thank you and blueyeguy for confirming with me that this issue still exists in 1.10.
  • I tried the patch posted by
    You need to edit the file /js/redactor-osticket.js:

     this.$draft_saved = $('<span>')
                .addClass("pull-right draft-saved")
                    //.text(__('Draft Saved')));
            // Float the [Draft Saved] box with the toolbar
            if (this.opts.draftDelete) {
                var trash = this.buttonAdd('deleteDraft', __('Delete Draft'), this.deleteDraft);
                this.buttonAwesome('deleteDraft', 'icon-trash');

    Tell me if it works :)

    But unfortunately this doesn't solve the problem.
    As long as agents can not reply by email I strongly suggest to get increase the priority of this issue.

    My agents have to reply long texts often and are really (really really really) complaining about this.

  • There is a new redactor which can be find on Github which almost completely fixed the problem.

  • edited May 2017
    @Richard63 Would you be so kind to give ma a hint where I can find it on GitHub?

    Seems that it's no more available or I'm just unable to find it...
    I found some older releases here and here. The second one seems to work in fact but I'm quite unsure if this is the right one...

    For the impatient : Download redactor.min.js and replace
  • @Nanocosm: It is still available, can't imagine discussions at Github would be removed.

    It is spoken of in an issue of the 1.10 RC1 version which is maybe why you did not find it at first.
  • issue reports at github are not removed.  They do get closed once they are resolved however.
  • edited May 2017
    @Richard63 ...Sorry I wasn't clear.

    I wanted to know where do I get the recent version of redactor.min.js on github. I just found probably older versions 8.2.2 and 10.2.5. on github in my post above.

    There isn't any reference for the code on nor the current version number.
  • I don't have any newer version then 10.2.5 which worked for me.
    However, reading the thread on Github, this seems not to fix it for everybody. Since that time there were also some Firefox updates.
    I don't have any issues at the moment using 10.2.5. Well.... only once but could not reproduce it later anymore.
  • I was doing some research into this also as I am having an issue where any XML tags I enter in a ticket response are stripped by the editor in OST v1.10

    As far as I can tell, after 10.2.5 the code was made closed source and commercial and Imperavi started working on redactor II.

    I did find a redactor.js (not min) for 10.2.5 and plugged that into OST and messed around with the code but my Javascript foo is not up to resolving my problem unfortunately.

  • @Cjhabs: read a bit higher, Nanocosm has put a link to the 10.2.5 redactor.min.js as far as I know that was the last public or at least the last free version.
  • Yes, that is what I said, that after 10.2.5 the code was made closed source.
    Also,  I found a non-min version of the js to try to hack it to fix my issue - also 10.2.5 - but was unable to fix my problem.

  • I'm sorry, I've misread a little, you indeed declared that already.
    Did you also try to disable some of the other options, like disabling or setting a higher value of autosave? I think the methods were mentioned on page 1.
  • My problem is not the backspace problem - I reported it as a separate issue where xml tags in tickets responses are dropped from the saved response. This worked in 1.9.x.
    @ntozier suggestion to attach the xml instead of inline, while it works, is not useful for the type of repsonses we often make where xml code is interspersed through the response.

    As I said, that is a separate ticket that I suspect will not get resolved as the free version of redactor is no longer supported and has not been for a while.
Sign In or Register to comment.