Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Attachments not being uploaded for tickets from staff control panel.

Osticket v1.10 (901e5ea)

1) We receive a ticket
2) We want to attach a file to the ticket when we reply
3) Attachment is appearantly uploaded, but is not actually added to the ticket.
4) When entering the ticket, the text-reply is posted, but no attachment.

SOMETIMES, the attachment does work and is attached, sometimes not. Even though we do the same steps every time. Same attachment (size&filetype&filename).

We try to reproduce, and sometimes we can, and sometimes we can not. We tried with Internet Explorer, Chrome and Firefox, and we have the same issue with all browsers. Please advice.


  • edited May 2017
    Version info. (actually i also attached an image here, but it is not displayed!) 
    Server Information
    osTicket Versionv1.10 (901e5ea) —  Up to date
    Web Server SoftwareApache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.19
    MySQL Version10.1.14
    PHP Version5.6.19
  • "We want to attach a file to the ticket when we reply"

    How are you attaching the image?
    Inline image attachment (drag and drop to body)?
    email attachment (drag to the drop box)?
    Clicking the add attachment button on the editor?
  • @ntozier Clicking the add attachment button, browsing for the file, and uploading.
  • I have never had a problem with that.  In fact its the only way we add attachments here because it's been the only one that ever has worked for us reliably.
  • I too am experiencing exactly the same on OSTicket v1.10 (901e5ea)

    We attach package labels to incoming tickets, sometimes they stick, sometimes they dont.
    Cant seem to find an angle to attack the problem, nothing indicated in log files.

  • edited August 2017
    Adding my contribution. Having the same problem with a slightly different setup
    osTicket Version v1.10 (901e5ea) 
    Apache/2.2.22 (Debian)
    MySQL 5.5.33
    PHP 5.4.45-0+deb7u8

    agents are using italian language pack.
    Problem occurs around 15% of the time - haven't been unable to re-create the problem nor find the direct cause of the problem. Seems to occur randomly.

    tried with and without the plugin to save files on the filesystem - no difference.
  • Are you getting any errors in the JavaScript console? Or server logs?
  • nothing of value in the server logs and unfortunately, on my side I never managed to re-create the issue - I was planning on connecting to an agent's PC later, open her a console and monitor the situation while she works on OsTicket.
    I'll give another feedback later with anything useful I find among the browser logs.
  • Hello again. 
    Except a warning about a a deprecated function in a js, which I'm certain is not causing the problem as it appears everytime, this time there was a strange 404 error.

    the Warning: filedrop.field.js?901e5ea:51 [Deprecation] 'webkitURL' is deprecated. Please use 'URL' instead.
    > beforeSend @ filedrop.field.js?901e5ea:51

    the ERROR:
    :8080/scp/ajax.php/lock/3862/ticket/2275/renew Failed to load resource: the server responded with a status of 404 (Not Found)

    considering what I've learned so far, I believe it's either:
    * something regarding sessions duration
    * something regarding locks
    * something regarding the save-draft feature
    because the only times an Agent sent a reply and the attachment was stripped, was in a situation where he/she took quite some time writing the answer.

    any idea anyone?
  • Most of the time that locking fails its due to time zones not being set correctly in:

  • edited February 20
    Having this same issue on my instance

    Has anyone come up with a fix?

    osTicket Versionv1.10.1 (9ae093d) —  Up to date
    Web Server SoftwareMicrosoft-IIS/7.5
    MySQL Version5.7.20
    PHP Version5.5.8
  • @eric545

    please start your own thread with your information and what the issue you are having is.  AFTER you make sure that your timezones are matching in all the places mentioned in the thread.
  • Did anybody find the cause of this yet...?  Or better, the fix?

    Happening consistently here - try dragging 4 or 5 files of a Mb or so each onto the drop zone of a response.  Don't believe it's anything to do with timing or locking - times and timezones checked, I can open a ticket, respond straight away and it happens.  Have tried leaving it a few seconds after attachments uploaded in case db commit is async from upload, but no difference, only the last file is attached, and can verify same in the db.  Needless to say, agents are losing confidence at this point.

    Same as @azorlone, got the deprecation warning in console once, but otherwise nothing in server logs or console, and all upload requests from browser completed 200 OK.
    osTicket Versionv1.10 (901e5ea)  Upgrade— v1.10.1 is available
    Web Server SoftwareApache/2.4.6 (CentOS) PHP/5.6.36
    MySQL Version5.5.52
    PHP Version5.6.36
Sign In or Register to comment.