Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

[resolved] Error 500 on PHPFPM and HHVM incomplete headers

Hello,

I'm using Debian, ispconfig 3.1.3

The tables don't get created in the database. Permissions on the ost-config file are fine,  php info page works fine. All requirements for OSticket installer are met except the acpu cache but I use XCache so it shouldn't matter.

PHP Version 5.6.30-0+deb8u1

mysql -V
mysql  Ver 15.1 Distrib 10.0.30-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2


Error.log



[Sun May 21 00:09:34.100218 2017] [fastcgi:error] [pid 18541] [client PRIVATEIP:62132] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client3/web3/cgi-bin/php5-fcgi-HIDDENIP-80-HIDDENADDRESS.com", referer: http://HIDDENADDRESS.com/support/setup/install.php


Thanks

Comments

  • My first guess would be that for some reason the script is taking too long to execute and your running into the max execution time in your php.ini.

    Does the file exist?

    Is it possible that your fastcgi process is not authorized to read the files in that file tree?

    Either way this sounds like a server configuration issue to me, but I'm not real versed on PHPFPM and HHVM.

    Is this helpful?
    https://serverfault.com/questions/646245/php-fpm-failed-to-connect-to-fastcgi-server
  • It's definitely not time because the error happens immediately and php.ini gives scripts plenty of time. 

    The stack overflow isn't quite what I'm after either. Other scripts do work as I was able to install things like octobercms and wordpress.

    I have some other php options that I could try like cgi, fast-cgi, and mod-php.  

    Are there any other logs I can check to see if there is a different error maybe?
  • Okay, so I finally got it working with php-fpm on ispconfig.


    I had to setup a custom php option in the users website to turn off opcache.

    opcache.enable=0


    Please mark this as resolved!

  • Thank you for letting us know, it's always appreciated. 
This discussion has been closed.