Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

WYSIWYG Editors Not Working

None of the WYSIWYG editors seem to be working properly? I can't format text at all. Other functions like line, table, etc work fine. I just can't do anything with text. This includes all editors.

osTicket v10
Linux: CENTOS 6.9 x86_64 virtuozzo
Apache: v2.4
PHP: v5.5/v5.6/v7.0
MySQL: v5.6

Browser: Chrome 


  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    There is no v10.  So I presume that you mean v1.10.
    You might want to post a screen shot.
    You might want to specify the actual version of PHP your running.
    CentOS are you running SELinux?
    POPUP blockers?
    Error messages?
    PHP error messages?
    Apache error message?
  • Yes, v1.10 (typo)
    Screenshot of what? It's a function not working. You can't screenshot that!
    Those are the PHP versions I have installed and attempted to see if it was a PHP version issue.

    No error messages. Nothing. Just highlight, click BOLD, and the highlight goes away but it's not bold.
  • I've never seen or heard of this happening with to anyone else. 

    Chrome version?

    POPUP blockers? noscript? or other plugins?

    If you click on the <> does the htlm for the formatting show up?

    Have you edited or change anything in the core files?


    Admin panel -> Settings -> System
    Do you have Enable Rich Text: checked?
  • I couldn't find anything in the forums, either.

    Chrome: Version 58.0.3029.110 (64-bit)
    No pop-up blockers, etc.
    The HTML view has no code tags before or after attempting to change font.
    Nothing changed in core files. (I installed a second osTicket on another domain and it does the same thing.)
    SELinux - Redhat (RHEL distribution)
    Rich text for e-mails is set.

    I just tried in Firefox and it works. So, it's something with my Chrome it appears? I have no idea what would be causing this? I have no problems with any editors, including this one in this forum. bold green red

    The editor does have functions that work. It's just those functions that impact the text. Very strange.
  • I do have plug-ins in Chrome, but none are directly related to editors or such? Google calendar, PDF, Honey, etc.
  • I disabled all plug-ins in Chrome and same issue. So, it's not plug-in related.

    I disabled Webroot. No change.
  • Here is something funny...

    I switch to HTML view in the editor and added bold tags to a word. In WYSIWYG view, it does display in bold! Then, I can bold or un-bold it just fine for only that one word.  Then, I switched to HTML view, did nothing, then switched back and I can't bold anything including that word again.  So strange.
  • Hi Scott,
    I do have same issue since about 2 weeks.
    Tried to disable all plugins and extension, to clean cache etc but no luck at all.
    Other strange thing is that bullets or numbering work well
  • Hello, I have noticed same behaviour recently since my php 7.0 (CentOS 7) got upgraded to 7.0.18-1, where previously 7.0.17 was working fine for me, so it might be related to this upgrade.

  • Hi,
    still same problems here.
    Actually I'm using PHP 7.0.19 (Centos 6.5)
  • I am seeing the same issue and posted my solution in another thread.
    I resolved it by installing jquery-1.12.4.min.js (I believe v1.10 came with 1.11.2)

    I found if you highlighted a "space" it would bold/italic as expected but not if there was no space in the highlighted text.

  • Hi cjhabs,
    what do you mean with "installing jquery-1.12.4.min.js" ?
    Should I replace jquery-1.11.2.min.js file with  jquery-1.12.4.min.js and rename it in order to avoid substitution inside code?

  • I actually edited the files that call the jquery library:

    were the only 2 files I found.
    If you are running Linux, from the root of the osticket install run:
    grep -irl  jquery-1.11.2.min.js  */*
    to get a list of files that call this library.

  • Thanks for advice,
    actually I've also edited :

    so -> grep -irl  jquery-1.12.4.min.js  */* returns:
    • include/.MANIFEST
    • include/client/
    • include/staff/login.header.php
    • include/staff/

    well looks it solved using firefox while still unable to "bold" using Chrome
  • I'll retest here when I get a chance - I am using chrome with an Ubuntu client - is your client windows?
  • yes it a chrome client [version 58.0.3029.110 (64-bit)]  on Windows 10
  • Same here. Chrome & Firefox, latest versions, Win10-64
Sign In or Register to comment.