Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Imap fetching


it's been more than a month that I am not able to configure the email fetching to create tickets. (attached is the issue)

I have followed the instructions step by step but yet not succeeded.

noting that the "imap" is enabled for the mailbox.

I have tried o do it with an Gmail account as well but still same issue and error.

  • Osticket version: 1.9.14
  • Web Sever Software: Apache/2.2.27 (Unix) mod_ssl/2.2.27 OpenSSL/1.0.1e-fips DAV/2 mod_bwlimited/1.4
  • MySQL Version: 5.5.55PHP Version
  • PHP Version: 5.4.30
  • Email platform: office365
I would highly appreciate it if anyone could help me with this.


  • edited June 2017

  • The remote server is rejecting the connection.

    One of the following things is happening: 
    1. you do not have IMAP configured and enabled on the remote server
    2. your user does not have permission to connect via IMAP
    3. your username password combo are not correct
    4. your webserver does not have permission to connect to the remote server
    5. you have a firewall between you and the remote server, 
    6. your ISP is blocking those ports.
    Based on the error at the top "Invalid login" I would say that the most likely is 2 or 3.
  • thank you for your reply and concern.

    1- the imap is configured and enabled on the remote server.
    2- the mailbox has permission to connect via imap and I tried it with different system
    3- I made sure to enter the password correctly
    4- I am not sure how to check this one.
    5- No firewall
    6- not teh case

    still I get the same error

  • Well we use o365 Exchange and do not have this problem so you should probably double check all those things.  Remember IMAP is not enabled in Exhcnage by default, and Users do not have IMAP permissions by default either. (Outlook <-> Exchange uses MAPI last I checked)
  • try SSL:\\ in front of 

    • IMAP uses port 143 , but SSL/TLS encrypted IMAP uses port 993 .
    • POP uses port 110 , but SSL/TLS encrypted POP uses port 995 .
    • SMTP uses port 25 , but SSL/TLS encrypted SMTP uses port 465 .
  • @ntozier: thank you but I really tried and made sure that its enabled I even went I did it again just to double check through the power shell. just tried it with another system and it worked.

    I had the same issue with the smtp and I searched about it and I found the solution for that which in the smtp.php I should change $this->_socket_options =$socket_options; to $this->_socket_options = array('ssl' => array('verify_peer_name' => false));

    now the smtp is working just fine but the imap is driving me crazy I looked everywhere I tried as per my knowldge but no luck.

    @synt4xerror thank you for the info but I tried that it doesnt work
Sign In or Register to comment.