Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

bug: scp tooltips are not working correctly > php 5.6 to 7.0 cgi or fpm, cgi_fix_pathinfo=0 or 1

We tried different php versions from 5.6.latest to 7.0.latest as cgi and fpm and didn't get the tooltips working correctly.

In the cgi versions we tried to set cgi.fix_pathinfo=0 or cgi.fix_pathinfo=1 in the serverwide php.ini, doesn't help. We dropped a local php.ini in the root directory and tried both setting, doesn't help. We dropped a php.ini with cgi.fix_pathinfo=0 in the scp directory and it helps, but only if you are stay logged in with a valid session while changing the setting. After logout only a white page appears and you can't log in anymore. Strange. Any tips?

By the way: the tooltip appears, but is empty. Firebug doesn't show any helpful information...

Best regards,
Jürgen
Tagged:

Comments

  • Which tooltips are you missing? They work on mine (tooltips are defined in the markup already, so don't actually trigger any ajax etc). 

    Or do you mean Popups? Those semi-modal ajax-generated boxes for assigning agents and transferring etc?

    If you've turned on any error-logging, turn that back off again to see them, ajax errors show up as nothing at all.. so you can't use the ajax generated modal dialogs.

    Or maybe show us a screenshot of what's wrong?


    "After logout a white page appears" .. yes, you've got something wrong with your server mate, that's more serious than a few tooltips!

    Have you modified your code? Try restoring it and see if it happens again. 
  • edited July 3
    Hi Grizly, the error appears in unmodified and modified osTicket installation. If we make settings in the global php.ini, it doesn't have any effect. This means: disabling/enabling works and it is displayed und Admin Panel > Dashboard > Information correctly, but didn't have any effect. Error Level reporting is set to all.

    Additional information in Agent Panel > Ticket > Preview e.g. moving mouse over ticket number are displayed correctly, only the ajax information while moving mouse over the orange circle with the questionmark are not displayed. But the debuggers are not showing an error...

    "GET /scp/ajax.php/tickets/1/preview > will generate no error and shows the preview correctly
    "GET /scp/ajax.php/help/tips/tickets.queue > will generate no error and shows nothing

    The white page appears only if a local php.ini is dropped to scp. The server settings are correct and in any other installation, we have no problems with local php.inis, except in osTicket.

    Many thanks for your help.
  • Oh cool, didn't know it did that! :-)

    I get an application/json response with JSON data in it for the second query.

    Local PHP.ini dropped into SCP? Why would you do that? Do you mean the /osticket_installation/scp folder? 

    It's not a separate application, the /scp is a part of the whole application. If a php.ini just for that folder changed things like include_paths and whatnot, then it would break it.. the application root must be the parent folder of that for things to work properly. 

    What have you got in your custom php.ini?
  • edited July 6
    We are very irritated about this behaviour and are going in server settings, maybe there went something wrong. Never have seen such a behaviour before.

    Our servers are configurated in such way, that you can drop local php.ini in folders and subfolders, which are overwriting the global php.ini values for this specific directory. Settings are inherited to existing subfolders. In this case we can see that the global php settings are ignored and a local php.ini works, but generates a white page.

    I will post further information, when we have the solution...
  • FYI, you can use .htaccess to override php settings per folder.

    php_value setting_name setting_value

    Might save a bit of trouble your end.. what values are you putting in there?
Sign In or Register to comment.