Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

1.10 Update is frozen on the "pending page"

The only page we can get to is the log page. 

DB Error #1146 is the latest.

Looking for more useful data we downloaded the error log which is attached.

Any insight in to why this seems to have failed would be appreciated.


upgrading from 1.9.14 to 1.10

server info:
Apache Version2.4.27
PHP Version5.6.31
MySQL Version10.1.25-MariaDB
Architecturex86_64
Operating Systemlinux


Path to Perl/usr/bin/perl
Perl Version5.16.3
Kernel Version3.10.0-514.21.1.el7.x86_64


Comments

  • No attachment
  • attachment attached hopefully this time.
    error_log.txt
    42K
  • Trying again...
    error_log.txt
    42K
    error_log.txt
    42K
  • So just to shake the tree... 

    I did RTFM and followed the simple upgrade instructions.... twice.

    After the first... nothing seems to be happening, i restored the site to 7/30/17 and attempted again.

    The logs give an DB error with a code but searching for what that code means turns up nothing... Is the error code real or just something to look more useful then "Error Code: AFU"


  • There is a lot of memcache warnings, but this stood out:

    [31-Jul-2017 17:44:56 UTC] PHP Fatal error: Uncaught exception 'InconsistentModelException' with message 'Unable to prepare query: SELECT A1.* FROM `ost_translation` A1 WHERE (A1.`lang` = 'en_US' AND A

    Do you have other languages installed? If so, have they been upgraded as well?
  • Hi Grizly, Thanks for the help

    I assume the other languages have been updated. I followed the instructions and after backing up copied all the files and folders from the upload folder with the new code.

    We never did anything with languages prior so the old files would have been whatever was in the previous version.
  • Might be related to https://github.com/osTicket/osTicket/issues/3448 are you using the LDAP plugin?

    Hmm, DB Error 1146 means the table doesn't exist. 

    So, I would guess that the upgrade failed to finish, and it b0rked before creating the translation table.  You should have received an error email/admin-log message about that, and the upgrader interface should have also shown the that something went wrong. I'm not a fan of recursive ajax requests, but that's how it works. 

    I'd try running the upgrade in CLI mode first, before looking at manually applying SQL patches, for instance:
    php manage.php upgrade
    That should spit out any errors that are causing the problem, alternatively, you could try and manually repair it:
    Looks like the translation table is part of the b26f29a6-1ee831c8.patch.sql file in /include/upgrader/streams/core/
    You'd have to do a find/replace %TABLE_PREFIX% before manually running it.. I assume you have a backup!




  • edited August 1
    Thanks again.

    I can roll back to 7/30 and our previous version. 

    We are not running any plugins or mods.

    Given the fact that we don't do any mods. We run OSTicket right out of the box, I looks like there's something wrong with the updater.  

    I saw a screenshot on another site of what the upgrade window now looks like. I never get the black progress box. clicking on upgrade now does nothing.... other then have it say at the top "Upgrade Pending"

    We've run several upgrades since we first installed OSTicket a few years ago without a hitch.

    Tried running manage.php from the CLI and got:

    [root@six helpdesk]# php manage.php upgrade

    Content-type: text/html; charset=UTF-8


    Management only supported from command-line


    If I were to restore back to the previous version is there something I can check prior to attempting the upgrade again. FWIW - I've restored and tried the upgrade after the initial attempt.

  • Maybe you didn't override all the files with the upgrade? Because mine doesn't set a content type header in CLI mode.
  • I just re-uploaded the files from a fresh download. I'm pretty sure that all were transferred. Status unchanged but it's possible that the database is corrupted from the failed attempts.


    I'm restoring back to the last version 7/30 as we need to have this back up and running.

    Can you suggest anything I can do to look at our files prior to attempting another upgrade?

    Thanks again for your help.
  • I'm almost out of ideas mate, there might be something customised about the config that it doesn't like, a particular version of MySQL or php config that is causing enough weirdness to break it.

    I recently ran upgrades from our long running 1.7 install all the way to 1.10, and it worked, I tested it several times before running it in prod, it took hours to process, many gigabytes of data..

    And mine has many plugins and customisations.. so if anyone was going to experience it breaking, it would have been mine. Which is what's confusing about your issue.

    Your kernel is pretty old compared to mine, which shouldn't be an issue, and I've not tried an EL server in years.. are you running CentOS? Or RedHat?

    Perhaps a script is assuming that a module is installed that isn't, maybe you can try transferring a database backup to an Ubuntu VM and try the upgrade again. A bit harsh..
    Have you recently upgraded PHP or MySQL as well?

    CentOS, hmm, it might be an selinux thing, or even permissions of Apache itself, the upgrade process creates a few temp files that it might be failing to do if it can't write to the application directory.. that's not great actually. Hopefully it's not that.

    I wonder if it's a tmpfs storage issue, how much tmp do you have free?
    What else is running on the box? Is it your server or hosted? You're not running out of inodes or something weird? Hmm, there's loads of possibilities, but figuring out exactly what is going wrong is challenging.
  • Thanks for all the brainstorming. We recently were force migrated from one server to another as our hosting company was sold to another company. They said they were cloning but in reality they did a new server build and then just migrated our cPanel accounts so I'm trying to figure out what's different....


Sign In or Register to comment.