Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Error HTTP 500/502.2 during installation

I am currently trying to install osTicket v1.10 on my companys server an i cannot get the Setup to ro run. I followed through all steps, but when i vistit the URL http://support.fwp.at/setup/ or alternativley http://support.fwp.at/ i am just getting a http 500 error.

I already tried the following steps to get rid of the problem:


1) Executed the script in cmd line:

C:\Program Files\PHP\v7.0>php-cgi.exe C:\inetpub\wwwroot\osTicket\index.php

This throws the same error 500 as it does when i navigate to the URL in IE or Edge. It states http://support.fwp.at:80/setup/index.php as source as requested URL.

C:\Program Files\PHP\v7.0>php.exe C:\inetpub\wwwroot\osTicket\index.php

This executes without throwing an error though - so i thought it might be fastCGI that' s causing the problem and i tried changing the php handler in IIS to the normal php.exe without fastCGI. This though only modifies the error message: instead of 500, i am getting 502.2 bad Gateway instead with the following detailed Information given:

Error Code: 0x000000ff

Handler: PHP_via_CGI

Returned HTTP Headers: " "

2) I tried using different versions of PHP - 5.3, 5.6, 7.0 and the behaviour described in 1) did not change at all. Same errors over and over again. I installed the differenmt PHP versions and the other dependecies of osTicket specified here (http://osticket.com/wiki/Installation) via the IIS integrated web platform installer, so i assume everything was installed properly. A friend of mine though said i maybe missing some PHP extensions - do you know anything i could be missing?

3) Checked if permissions are fine. IIS_IUSR which i assume i need for anonymous authentification and the app pool user i created for osticket both have full acces on file system level.

4) DNS Integration of my URL has been done properly.

Environment:

Server: Wind 10 Pro x86

IIS: 10.0

PHP:  7.0 (tried 5.3, 5.6 as well)

MySQL 5.5

Comments

  • Error logs (seemingly i cant upload the file):

    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) cs(Referer) sc-status sc-substatus sc-win32-status time-taken
    2017-08-08 14:48:24 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 500 0 0 354
    2017-08-08 14:54:44 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 500 0 0 373
    2017-08-08 14:56:06 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 72
    2017-08-08 14:58:40 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 37
    2017-08-08 14:58:41 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 46
    2017-08-08 14:58:43 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 37
    2017-08-08 14:59:04 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 403 1 5 0
    2017-08-08 14:59:54 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 1113
    2017-08-08 14:59:55 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 53
    2017-08-08 15:00:16 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 46
    2017-08-08 15:00:17 10.199.43.51 GET / - 80 - 10.199.43.22 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+InfoPath.3;+SLCC2;+Media+Center+PC+6.0) - 502 2 255 53

  • Ok it seems to work with osTicket 1.9.15. Still i would like to get the most recent Version 1.10 up an running,
  • Good explanation of the problem and information provided.  The only thing that I think I would need to investigate this further would be the PHP error log.
  • Here are the PHP logfiles from the last two days. Currently i am running osTicket 1.9.15 with PHP 5.6 and mySQL without problems. I think it s got something to do with the new 1.10 version.
    PHP53_errors.log
    4K
    PHP56_errors.log
    4K
    PHP70_errors.log
    43K
  • I specificly need the php 5.6 error logs when you try to install 1.10.
  • Ok thanks i am going to get back at you with the php5.6 logs next time i try to install v1.10. Right now i am exploring 1.9.15 to see if it fits my companies Needs..
Sign In or Register to comment.