Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Tickets time is not shown correctly

My Server, php.ini & Mysql timezone is set as Asia/Kolkata , but ticket time is not shown correctly.

pfa, system info as displayed by osticket
-----

About this osTicket Installation

Server Information
osTicket Versionv1.10 (901e5ea) —  Up to date
Web Server SoftwareCentOS 7: Protected by Mod Security
MySQL Version10.1.22 ( MariaDB)
PHP Version7.0.18

PHP Settings
cgi.fix_pathinfo "1" is recommended if AJAX is not working
date.timezone Asia/Kolkata
Database Information and Usage
Schemab****_ticket (localhost)
Schema Signature********************
Space Used194.83 MiB
Space for Attachments181.98 MiB
TimezoneIST (Interpreted as Asia/Jerusalem)

Installed Language Packs

English (United States) —

en_US — include/i18n/en_US
---------------------------------

TimezoneIST (Interpreted as Asia/Jerusalem)
Couldn't understand IST ( Asia/Jerusalem ), from where this is picked up.

Pls help, there is some 40 minutes difference.

Comments

  • There is a pull request at github that should help with this problem until the change is included in a future version.



  • edited April 26
    hi,

    checked system settings, Actual Time is 26/04/2017 19:28 & there is no option of Daylight saving.

    ---



    Date and Time Options 


    Default Locale:

    Default Time Zone:     Asia/Kolkata







    Date and Time Format:












    Time Format:

     


    02:27 PM

    Date Format:
     


    26/04/2017

    Date and Time Format:
     


    26/04/2017 2:27 PM

    Day, Date and Time Format:
     


    Wed, Apr 26 2017 2:27 PM      
    ----          
  • I'm not sure why your post is like 3 pages long what amounts to about 8 lines of text... so I can only conclude that you are copying and pasting from some place.  What is it that you want us to glean from your malformed response?

    "My Server, php.ini & Mysql timezone is set as Asia/Kolkata"

    osticket timezone? agent account time zone?
  • edited August 18
    HI ,

    I have the same issue , i am getting 2.30 hr of difference from the actual time.

    and in php.ini, mysql, osticket admin login,agent login , the timezone is Asia/Kolkata only but still am unable to fix this

    Am using
    osticket version- v 1.10
    webserver software - Apache /2.4.7
    Mysql version- 5.7.19
    PHP version - 5.5.9-1
    OS - Ubuntu 14.04 server os

    Please help me to fix this issue

    imageimage
    Capture5.JPG
    932 x 245 - 44K
    Capture6.JPG
    986 x 169 - 40K
  • edited August 18
    If you look closely, you'll see Timezone as " IST (interpreted as Asia/Jerusalem)", next to your database. Now, I don't know why we can't just store timestamps, maybe after all these issues they'll move to that, but it looks like you need to set your database timezone.
    There are a few ways of setting that, see https://stackoverflow.com/questions/3451847/mysql-timezone-change

    FYI: the difference between those two Timezone:
    Kolkata, West Bengal, India is 2 hours and 30 minutes ahead of Jerusalem, Israel
    12:37 am Saturday, in Jerusalem, Israel is
    3:07 am Saturday, in Kolkata, West Bengal, India
  • edited August 21
    Same issue shows Timezone as " IST (interpreted as Asia/Jerusalem)",

    [root@****** ~]# mysql -e "SELECT @@global.time_zone;"
    +--------------------+
    | @@global.time_zone |
    +--------------------+
    | Asia/Kolkata |
    +--------------------+
    [root@***** ~]# date
    Mon Aug 21 11:39:07 IST 2017
  • Can you provide the results of:
    USE mysql;
    SELECT * FROM `time_zone_name`;
  • It will show a lot if lines (more 1700).

    [root@**** ~]# mysql -D mysql -e "select * from time_zone_name" | wc -l
    1781
    [root@***** ~]# 
  • edited August 22
    Good that means your time zones are properly populated in MySQL.
    Now this please:

    SELECT @@global.time_zone, @@session.time_zone;

  • I made all the changes from that above link , but still unable to resolved the issue.

    And even i installed freshly on my VM with the same version v 1.10 , still same issue i am getting the same time zone (Jerusalem) instead of Kolkata in database.

    Can you please help me out how to change the date or timezone in osticket data base.

    Thanks & Regards
    Rajendra
  • edited August 23
    See below please:

    [root@****** ~]# mysql -e "SELECT @@global.time_zone, @@session.time_zone;"
    +--------------------+---------------------+
    | @@global.time_zone | @@session.time_zone |
    +--------------------+---------------------+
    | Asia/Kolkata | Asia/Kolkata |
    +--------------------+---------------------+
    [root@******  ~]# 
  • I checked mine, it's MariaDb, has zero entries in any of the time_zone fields, and the @@globàl was set to SYSTEM. But I'm not in Kolkata.. hmm
    Was meaning to spin up a server and check, but got busy at work. If you've a spare VM with it, try not setting it at all in MySQL, just the server.
  • I've asked a dev to take a look at this thread.
  • edited August 23
    Okay so the system is still interpreting your timezone as 'Asia/Jerusalem' which is a two and a half hour difference from 'Asia/Kolkata'.

    Edit include/mysqli.php and change line 118 from:
    return db_get_variable('system_time_zone', 'global');
    to:
    return db_get_variable('time_zone', 'global');

    After you do this save the file, refresh the Dashboard > System Information page and see if the timezone is now correct. If so, then retest creating a ticket to see if the times are correct.
  • done, still the same

    Actual time : 23:41 but Ticket creation time & Dashboard > System Information is still the same.

    ---- 

    Create Date:24/08/2017 2:11 AM
  • edited August 23
    My apologies as I seem to have drank a whole cup of stupid this morning. That wouldn't have worked because it only affects the Information page...doh. Upon ticket creation we use the SQL NOW() function.

    So run the following command in MySQL...:
    mysql> SELECT NOW();
    ...then log out of MySQL and run this in the command line:
    $ date

    Post both results for me please.
  • edited August 25
    the commands output below at that time:

    [root@**** ~]# mysql -e 'SELECT NOW();'
    +---------------------+
    | NOW() |
    +---------------------+
    | 2017-08-25 00:45:11 |
    +---------------------+
    [root@***** ~]# date
    Fr aug 25 00:45:15 IST 2017
    [root@****** ~]# 
  • edited August 25
    Asia/Kolkata (Interpreted as Asia/Jerusalem)

    PHP Settings
    cgi.fix_pathinfo "1" is recommended if AJAX is not working
    date.timezone Asia/Kolkata
    Database Information and Usage
    Schemab**** (localhost)
    Schema Signature***********  
    Space Used214.58 MiB
    Space for Attachments181.98 MiB
    TimezoneAsia/Kolkata (Interpreted as Asia/Jerusalem)
  • Edit include/mysqli.php and change line 118 from:
    return db_get_variable('system_time_zone', 'global');
    to:
    return db_get_variable('time_zone', 'global');

    This has resulted in Asia/Kolkata (Interpreted as Asia/Jerusalem)

    Pls let know from which file actual ticket created/ modified date is taken & lines to edit for displaying correct timezone. 
  • Hello @bankcircle,

    Okay, so I've been trying to figure out what's happening here on my free time and I have something for you to try. Please download the latest version 1.10.1 from http://osticket.com/download and upgrade your system. This update includes a fix for a MAJOR security issue, some other small bug fixes/additions, as well as some fixes for some time/timezone issues. I hope that once you upgrade your time issue will go away. So please test this and get back to me! (MAKE A BACKUP OF ALL FILES AND DB BEFORE UPGRADING JUST IN CASE)

    Cheers!
  • thanks, worked
  • @bankcircle AWESOME! I'm glad that worked for you! Cheers.
Sign In or Register to comment.