Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Setting up email using gsuite

am setting up email but i keep getting the attached error.please help.


  • Not seeing an attachment mate, make sure you're using the correct ports and use the ssl:// prefix.
  • That server is for relaying, like if you use postfix to relay from a bunch of internal devices with no authentication, you can then configure your IP in the g suite admin console and then have postfix use that relay from Google as it's "smarthost".

    You likely just want to configure osticket like a normal client, so use "ssl://"
  • Hi Have used the ssl:// and am getting below error

  • You'll want to enable authentication for one thing, maybe try it without the prefix. Maybe that's only for IMAP, can't remember now.
  • Network is unreachable? Can the server resolve the name and route to Google, then check the firewall to see if you're allowed out.
  • I just checked the wiki, there are steps just for Gmail!

    Gmail Configuration

    In order to use Gmail, your host must support SSL, so osTicket can negotiate the secure connection, and you must enable IMAP or POP in your GMail or GApps account. Configure in osTicket (the easy part)
    Under Admin panel -> Emails -> Emails -> Sending email via SMTP For most people, enter either ssl:// with port 465 or tls:// with port 587.
    note: If you have a google apps/G-Suite account, this might change, see below.
    Select "Authentication Required". Leave Header Spoofing unchecked. Make sure your username is your full email and password are set correctly in the Email Login Information
    If you test at this point and it doesn't work, continue reading.
    You may need to consult your PHP error log (the location varies by OS and personal preferences so consult your php.ini to determine its location). The PHP error log often contains more information as to why something is not working correctly.
  • Tried all this ,but still getting same error
  • Gmail is not GSuite.
    Pay specific attention to the "Check your G-Suite policies" section. 
    Check your fire wall locally, and any other security rules you might have on the webserver.
    You haven't told us what your OS is.  If you are running CentOS you should try disabling SELinux for a minutes and see if it helps. [if it does then you will need to write a rule allowing the connection]

    Something doesn't look right with your screen shots...  The orange bars specifically.  Are you running some sort of theme mod?
  • Hi Ntozier
    I have intalled the osticket on my cpanel see below the server details.
    I have checked the firewall and all this ports are open.
    About the orange bars am very good in CSS and was able to customize the colors into our corporate colors.
    see below also the settings i have done on gsuite policies
  • You need to lock down that relay service man, that's bad.

    Then configure osticket smtp server settings with: tls:// and port 587
    ssl:// with port 465

    You do not need to use the relay for osticket.
  • Hi Grizly
    I have tried both.See below
  • I go back to my previous comment which you might have missed?

    Network is unreachable?
    Can the server resolve the name and has a route to Google?, then check the firewall to see if you're allowed out.

    What kind of host is that? For instance Google cloud blocks all email, AWS instances are locked down till opened up.
    Have you contacted your server admin?
    You might even need to contact Google at this point, if you've been using an open relay they might have blocked you.
    The fact is, the software works with Google, and with gsuite Google accounts, so something on your end isn't setup correctly. Beyond time to start investigating the server's setup.
Sign In or Register to comment.