Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Disable automatic replies








osTicket Version v1.10 (901e5ea)
Up to date
Web Server Software Apache/2.4.18 (Ubuntu)
MySQL Version 5.7.19
PHP Version 7.0.22-0ubuntu0.16.04.1
Hello all, I am trying to figure out how to disable automatic reply emails from being sent on updates or status change. I know this has been answered before, because I have used it, but I can not find the post now.

Ex.

John opens a ticket and receives an email about opening a ticket.
When I update the ticket "Post a reply", I want to change the default option to be -Do not email reply-, instead of it automatically emailing a reply. I thought it was in tickets.php, but I cannot find it. It saves a set of having to select Do not reply from the drop down.

After updating to 1.10, we lost all of our customization and are trying to rebuild them.

Thank you.

Comments

  • You could just shut off the notification in the admin panel.

    Admin panel -> Settings -> Tickets -> Autoresponder 
    uncheck New Message options.

    and 
    Admin panel -> Settings -> Tickets -> Alerts and Notices
    uncheck New Message Alerts

    Althernative you could create a special department that replies are not send for.  Transfer it to that department and then reply.

    Admin panel -> Agents -> Departments -> your department.
    New Message tick Disable for this Department

    If you don't want to do it either of those two ways then you would have to edit the core sources files.
    See /include/staff/ticket-view.inc.php circa line 572.

  • Ours is already unchecked, but the notification emails still go out to the customer via email.


    ostresp.JPG
    698 x 489 - 63K

  • image
    ostresp.JPG
    698 x 489 - 63K
  • Looking at those again none of those check marks indicate a "send new message" to the user based on Agent activity.  I guess that it can't be disabled that way.
  • I believe I have found the post that I originally followed some time back, but the image is gone.

    http://osticket.com/forum/discussion/85363/option-to-disable-end-user-emails-how-to-not-send-emails-externaly
  • 829829
    edited September 1
    For anyone else also wanting this option see below for the change.

    [code]
    <?php
                        # XXX: Add user-to-name and user-to-email HTML ID#s
                        $to =sprintf('%s &lt;%s&gt;',
                                Format::htmlchars($ticket->getName()),
                                $ticket->getReplyToEmail());
                        $emailReply = (!isset($info['emailreply']) || $info['emailreply']);
                        $emailReply = "";   /* <-Add this line to the left, below the line above */
    [/code]

    Admin, please feel free to make this as solved. Thank you.
Sign In or Register to comment.