Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

%{response} not translated for collaborators

If we add a collaborator to an OSTicket ticket, and then reply to that ticket, collaborators only get an email that looks like this:

--------------------------------------
%{response}

(Signature properly displays here)
--------------------------------------

The response variable is not translated to the actual reply added to the ticket.

The original user who created the ticket receives the reply with the %{response} variable translated properly. So this problem only affects collaborators.

osTicket Version v1.10 (901e5ea) —  Up to date
Web Server Software Apache
MySQL Version 5.6.37
PHP Version 5.6.28

Comments

  • This does not appear to be a suggestion or feedback.  Moving it to Troubleshooting and Problems.

    When you say translating, you dont mean languages.  You mean the variable was not changed to the actual response.  Have you tried the %message variable.
  • Here is what I get if I try to change from %{response} to %{message}

    Some variables may not be a valid for this context. Please check for spelling errors and correct usage for this template. 
    %{message}
    Email Subject and Body:

    Re: %{ticket.subject} [#%{ticket.number}]
    %{message}

    -- Please do not reply below this line --
    If this issue is still unresolved, please do not start a new email. Instead, reply to this email to keep all correspondence about this issue linked to this email thread.

    It seems like the %{message} variable is not meant for the Response/Reply Template.

    Something interesting happens though when I try that:

    The reply message I get for the main user on the ticket looks like this now (notice with the %message variable it does not populate anything):

    %{message}

    -- Please do not reply below this line --
    If this issue is still unresolved, please do not start a new email. Instead, reply to this email to keep all correspondence about this issue linked to this email thread.

    But the emailed reply message received by the collaborator looks like this (notice that it still shows %response and hasn't updated to %message):

    %{response}

    -- Please do not reply below this line --
    If this issue is still unresolved, please do not start a new email. Instead, reply to this email to keep all correspondence about this issue linked to this email thread.

    It seems like replies going to collaborators are not following the template properly.
  • Thanks ntozier,

    I was able to figure this out based on what you said.

    I wasn't aware that the message template for collaborators was different than the one for the ticket user.

    I see now that I needed to edit the New Activity Notice template for collaborators and edit the Response/Reply Template for ticket users.

    The %{message} variable is the correct variable to use for the New Activity Notice. While %{response} is the correct variable to use for the Response/Reply Template.

    All is working as expected now.

    Thanks again.
Sign In or Register to comment.