Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Duplicate tickets per mail are getting created

Hello,

I am facing a strange problem in my prod environment where multiple tickets per mail are getting created. It is not always reproducible, but is happening at least 10% of the times. Here are some of the scenarios of my setup:

  • Multiple email accounts have been setup (each fetching at 2 min interval)
  • Cron setup at 2 min interval
  • High traffic - almost 5000 new threads get created per day
  • Each email address is part of the group which receives that mail.

The problem is not at the time of replying, but at the time of new ticket creation. Can someone help out on how to handle the situation?

As for the deployment details:

- v1.10

- Linux (Ubuntu v16)

TIA

Comments

  • You haven't told us the following:
    • how many emails you are fetching ever two minutes.
    • version of PHP
    My first guess would be that the first cron hasn't finished collecting and processing the email, and the second cron is running and grabbing the same emails.
  • - Number of emails fetched by auto-fetch is 127 per account.
    - PHP version is 5.6.31


  • Sounds like your crons are running into each other.
  • Since I have only 1 cron setup, so would individual mail fetching be interfering with cron? If so, should I be switching off individual mail fetching and only let cron run?

  • What I understand is that there are 3 types of fetching happening here:
    1. Cron fetching (scheduled as defined in crontab)
    2. POP/IMAP fetching (scheduling as defined in the email settings)
    3. Auto-Cron (happens as the user activity happens).

    Is this understanding correct? Given this, how do I get just one setting on (AFAIK, switching off POP/IMAP will switch off cron as well).
  • edited September 12
    "Cron setup at 2 min interval"

    Cron runs and starts collecting 127 emails.  This likely takes more then 2 minutes.
    2 minutes later Cron fires again and starts collecting 127 emails.

    If you are running cron, you should disable Auto-Cron.
  • Thanks @ntozier. It really helps!


  • You're very welcome.  Have you adjusted the times or any other settings to try to see if this helps?
  • Have done the following settings (looks good so far, though will get a confirmation after 1-2 days run)
    - Auto-Cron is Off (this seems to be the trick)
    - Email fetch time is set to 2 mins
    - Cron set to 2 mins.

    Thanks again @ntozier for your help. 
    Cheers!
  • Very welcome.  Please let us know if you encounter any further issues with this. :)
  • edited September 15
    Continuing on the thread, disabling auto-cron was the trick. System is working like a charm.

    Just curios, why do we even have auto-cron in existence? Only scenario I could think of is the case when someone is unable to setup cron.


  • That's pretty much the reason mate.
  • edited September 15
    I think the auto-cron is good for testing or evaluating.

    But for production use I would disable it. 
    When somebody is not able to use a cron or rcron he should consider that he/she needs help/support for running osTicket..
  • Auto-cron is for those people who cannot or do not want to run a scheduler [cron/windows task scheduler].  It's not recommended for production use.
  • Got it. Thanks again!

    Cheers!
Sign In or Register to comment.