Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

canned.php not opening.

Dear all 
osTicket Versionv1.10 (901e5ea)   Up to date
Web Server SoftwareApache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips PHP/5.4.16
MySQL Version5.5.52
PHP Version5.4.16

Below link for canned messages not working, it was working previously. canned.php file size is 8.3kb and not edited. 

Its opens 

Frequently Asked Questions

Please find attached screenshot. Help Appreciated. 



  • Please help us to help you by reading and following the posting guidelines located in this thread: Please read before requesting assistance.  The more information you give us the better we will be able to assist you. Thank you.

    No screen shot
  • Has your account got permission to view it?
    When you say "not working", what do you mean, you showed a screenshot of it working.. which bit is broken?

    FYI: you might want to crop RDP data in future caps.
  • There's definitely something wrong. It should look like this screenshot:


    But in your case ../scp/canned.php is showing the faq section instead. Never saw such an issue.
    Could it be that you created redirections in your webserver config that are causing this?

  • edited September 2017
    I am admin of server, This is only standalone machine. there is no redirection to another server. Agents are able to use canned responses. currently i wanted to added new canned responce so this issue came up. i cant access the page. kindly help. i tried restoring original canned.php from backup SCP folder, still not working. 

  • I didn't think of a redirection to another server rather a mod_write rule.

    Or maybe an cache issue.
  • But does your account actually have the permission?
    You say staff can use them, so they are likely enabled, the only other check that would show kb.php instead is if your account doesn't have the permission.
    Snippet from canned.php:
    /* check permission */
    || !$thisstaff->getRole()->hasPerm(Canned::PERM_MANAGE, false)
    || !$cfg->isCannedResponseEnabled()) {
    header('Location: kb.php');

    To check yours, Admin panel -> Agents -> your account -> Permissions tab -> Knowledgebase sub tab, make sure that the box is checked.

  • @Grizly
    Does your osTicket behaves like you described?

    In my instances I can only remove the canned response access via the role permissions tab and then the menu symbol for the "Canned Responses" will disappear after that (his screenshots are showing the menu symbol still)

    Under account permissions I only have the option to remove the access for the knowledgebase (Ability to add/update/disable/delete knowledgebase categories and FAQs) and then the menu symbol for "Categories" will be removed.
  • hi Grizly

     I checked. please find below screenshot. Also canned. php i same as u mentioned. 

  • Nah, it doesn't, and if I turn off canned via scp/settings.php?t=kb then the menu item disappears.
    Found the one I was thinking of though, it's a role permission, so:
    Admin -> Roles -> your role -> Permissions -> Knowledgebase

    It does the same thing as disabling it though, not like your screenshot.. weird. I can't replicate it.
  • @jayesh_shertate can you attach your canned.php file?
  • All I can think is that canned.php is a symbolic link to faq.php.. 
  • edited September 2017
    I can only replicate this behavior if I replace the content of the canned.php with the content of the faq.php.
  • Please upgrade your PHP to 5.6.

  • i will check and upate you very soon.
  • Dear All
    please find attached canned.php. 
    Kindly support. 
  • Why are you attaching a file?
Sign In or Register to comment.