Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Can't login after upgrading to v1.10


Database: MySQL
Server version: 5.5.56-0ubuntu0.14.04.1 - (Ubuntu)
Web server: Apache/2.4.7 (Ubuntu)
PHP-Version: 5.59

Error E-Mails:

DB Error #1054

[SELECT page.*, count(topic.page_id) as topics  FROM ost_content page  LEFT JOIN ost_help_topic topic ON(  WHERE page.content_id=6 GROUP By]

Unknown column 'page.content_id' in 'where clause'<br />
<br />
---- Ablaufverfolgung ----<br />
#0 (root)/include/mysqli.php(177): osTicket->logDBError('DB Error #1054', '[SELECT page.*,...')<br />
#1 (root)/include/ db_query('SELECT page.*, ...')<br />
#2 (root)/include/ Page->load('6', false)<br />
#3 (root)/include/ Page->Page('6')<br />
#4 (root)/scp/login.php(26): Page::lookup('6')<br />
#5 {main}

The Issue:

Soon after upgrading from 1.8 to 1.10 I logged out of my Agent Account and can't login anymore (and also with no other account) - getting http 500 Error Code.


  • I would upgrade to php 5.6, clear your cache and try again.

    If that doesn't work I would also make sure that you uploaded the all the files to the site properly. [read this as re-upload the new core files from 1.10] content_id does not exist in 1.10.  It did exist in older versions however.
  • I already updated php to version 5.6 (before upgrading osTicket) through the terminal, but it was still 5.59 in the Information section in osTicket. I don't know why.

    I thought I did something wrong while deleting the setup directory and that the issue is my fault.
    So I tried uploading the old files and the upload folder again, but nothing changed. (Could that be the reason for this error email?)

    I have to look closer through the other emails, but I have no access to it right now, so I will report again tomorrow.

    Thank you for the help so far.

  • If it says 5.59 then that is the version that your site is running.  Perhapos you didnt restart your webserver service, or perhaps both are installed and the site is set to use the old version.
  • I tried removing old php files, but with "apt-get purge php5-common" it also deletes phpmyadmin.

    Is it safe to restore a backup of the whole VM?
  • I dont know what OS you are using but if uninstalling php 5.5 nukes your phpmyadmin you should be able to just reinstall it.  Or course since you used a -purge instead of -remove you likely nuked all your configuration files for it.

    Q: Is it safe to restore a backup of the whole VM?
    A: Only you can answer that. We dont know when you made your back up, what you did after the backup was made, and a variety of other variables.
  • Just reinstall phpmyadmin, it works with php7
  • Yeah I reinstalled it.

    Still no chance to log into osTicket.
  • Might be "restore the database from backup time" and do the upgrade again. 
  • Additional Information.

    Everytime i reboot the Server, the first time I login there is:
    "Valid CSRF token is required"

    And installing php7.0 hastn't change anything.
  • I did a full VM restore and osTicket is working again.

    I still have no clue what the issue was.

    What should I consider, if I want to upgrade again?
  • There's a few patches coming, I know for a fact one fixes the php7 login csrf issues.
  • Upgraded again. 
    Everything works.
    I log out and try to log in again -> HTTP ERROR 500
  • Did you apply the patch that @Grizly posted?

    Please consult your Apache and PHP error logs and provide any errors that are being logged.
  • Just a quick information (I will provide more soon):

    Upgrading to osTicket (v1.9.16) is working fine.

  • I am planning to update ubuntu, so I can update phpmyadmin and then I will update PHP.
    Then I will try again to upgrade osTicket to 1.10
Sign In or Register to comment.