Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Custom Field Issue

pripri
edited November 2017 in Suggestions and Feedback
Hi,
Board and Environment fields list a numeric code, which previously listed the corresponding string value (Board 7 corresponds to XYZ, for example). Now, the string value is no longer included with the numeric code for Board and Environment (see attachment). I want include both numeric code and corresponding string value in both of these fields. How to solve it?

image

Comments

  • pripri
    edited November 2017


  • pripri
    edited November 2017
    Please find attachment for version information of osticket.
  • I'm not real sure what you are asking.  Can you provide steps to replicate the issue so that I can try to replicate it before I report this to the devs? 
  • First I had insert Board field in custom list and then this field add in ticket details. When I create ticket and export that page, export csv file gives only numeric value in Board field, Not give string value of "Board Field" that i had selected while creating ticket.
  • I have made changes in that ajax.forms.php file but issue is not resolved
  • ntozier, please help me for this issue. I am still facing that problem.
  • Can you provide steps to replicate the issue so that I can try to replicate it before I report this to the devs? 

    Are you using a list or a choices field?

    screen shots?
  • edited December 2017
    I have seen this behavior in old pull request that was merged: https://github.com/osTicket/osTicket/pull/610
    Maybe this point someone in the right direction to understand why this happens and if there is a way to make it work..
  • First I added board list in custom list of osticket and then add this board field in the ticket detail of custom form. When I create a ticket by adding board name which is in that custom list, ticket is created. But when I export the tickets then I can't see board name in the board column in export file. I can see only the id number. Similarly it is happen with environment field.
  • pripri
    edited December 2017
    We are using list. Added 13 items in the list. Please find attachment.
  • @ntozier, I m still facing this issue. Please help me in this issue.
  • So wait your problem is just using the export button?
  • Yes, We are using export button to export the tickets.
  • I am unable to replicate your report on my installation.
    We have two lists  They are Location (24 options) and Program (64 options).
    Both of these fields are added to the built in Ticket Details form.
    Clicking Export at the bottom of the ticket list exports these fields with their appropriate values.
    We are running current (1.10.1) with a the LDAP search and plugin fixes from github.

  • We have Board and Environment Lists added within the application. When we export tickets from Agent Panel then it has been observed that all the tickets created before 1st December, 2017 have Board and Environment column values like "9, ABC" and "13, XYZ" respectively. Whereas all the tickets created after 1st December, 2017 have values as "9" and "13" respectively, the Board and Environment Names are not displayed. Please let us know if this is some new change or if we need to make certain settings on our end to make it display accordingly.
  • @pri Being that no one else can replicate this and it was working correctly before then it seems that you added a plugin, or some custom code, etc. that affected the way the value is exported/stored....I would look into what you added/changed around Dec 1st, remove the changes/additions you made, and test again to see if it works correctly. Cheers.
  • I am unable to replicate your report on my installation. There aren't any settings for this. My guess is that you broke something altering the code.
  • @pri Also, I just tested this on my v1.10.1 install and the value is stored in the database as '9, Cannon Camera' and I got the List value's Name in the export, not the number (eg. 'Cannon Camera'). So it definitely seems like it was some custom code/pulls that were added to your install that broke the way it saves to the database and exports.
  • @KevinTheJedi  I observed that when I hit the API to create ticket, then this issue happen. After API hit I export the tickets, I got only Id. 
  • @pri Create a ticket via the client portal or agent panel and see if it'll export correctly. Cheers.
  • @KevinTheJedi I created the ticket through agent panel as well as client portal. But I got same problem while exporting ticket.
  • @pri then something is seriously messed up with the way it's trying to store the value....mine is default and is storing like "9, Cannon Camera"...
  • @KevinTheJedi I tried with reverting all my custom changes in osticket but I am still facing this board export issue.
  • @pri Can you upgrade to v1.10.1 and re-try?
  • Thanx for the suggestion. I will try it.
  • I tried the solution given in https://github.com/osTicket/osTicket/issues/3264 thread. I comment the line no. 63 in class.export.php. After this export works but it only display custom field name and not a numeric code. Is there any other solution to solve this problem ?
  • edited May 14
    I have above same type of issue,

    my steps which I have follows
     my osticket version is 1.10

    1) create lists as department and region  as below in attachment(department.png, region.png)
    2) add that two custom list in ticket detail form for dropdown as below in attachment(ticket detail form.png)
    3) create ticket with selecting region and department from dropdown
    4) while export ticket is shows me id of that two fields instead of its value as par below in attachment(export.png)

    please help me to resolve this issue ASAP
Sign In or Register to comment.