Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Difficulties when creating/deleting items

I'm running into an issue where I'm having difficulty creating/deleting items (users, tasks, and tickets). When I go to create/delete a task, I click on the button to do so which brings up the respective window. The window looks fine. When I go to close out of it by finalizing the create/delete process, it sticks on Loading. If I do nothing, it will just stay there on loading. If I refresh the page, the new task/user will show up. When I was trying to create new tickets, it appears that the tickets were only halfway entered, as it shows there are tickets assigned to users, but they don't show up anywhere.

I don't believe this is the AJAX issue seen on other setups, as the window does fully appear and summaries show up. It doesn't mean it isn't a separate AJAX issue, but I'm not entirely sure where to start. My cgi.fix_pathinfo is set to 1.

I'm running osTicket 1.10.1 with MySQL 5.7.10 and PHP 7.0.27 on a Windows Server 2016 with IIS. I don't see any errors in the PHP or MySQL logs, and the only one I see in the IIS logs is an occasional 500 error apparently due to a timeout for FastCGI, which I feel is a symptom of the issue, but not the source.

Please let me know if you need any other information.


  • You could try downgrading to PHP 5.6

    Many people have reported issues while running PHP 7

  • I tried downgrading but got the same issue. 
    I feel like this might be connected to MySQL as it is the only thing that has changed since the install was working fine. I'll keep digging into that - if there is any other info that would help me narrow down the search, that would be great.

  • Have you tried enabling MySQL's Slow Query Log to see if it's due to extremely slow queries?

  • I reinstalled MySQL from scratch, and it looks like the problem has gone away. Must have been an issue in communication with the server.

Sign In or Register to comment.