Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Auto-assign by response has stopped working

We're busy setting up the site for an imlementaion, and for some reason, during testing, the auto assigning of tickets to the agent that responds has stopped working. No matter what settings we've changed, we just can't get it to assign.

Our environment is as follows:
osTicket Version:    v1.10.1 (9ae093d) — Up to date
Web Server Software:    Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16 mod_perl/2.0.10 Perl/v5.16.3
MySQL Version:    5.5.56
PHP Version:    5.4.16

Some system settings that may be relevant:
Claim on Response: Enabled
2 departments with their own email addresses

Emails are sent and received 100% perfectly, with responses being added to the tickets. It's just the auto assigning that's not working.

Is there any way to add more logging? In the system logs on the dashboard, all we get is "cron job executed []", and log level is set to "Debug".

thanks

edit: pressing enter while entering tags submits the post, but I wanted to add, is there any other info you'd need to assist me?
Tagged:

Comments

  • "PHP Version:    5.4.16"
    ^
    Please upgrade to PHP 5.6 and see if that helps.  5.4 is ancient.
  • Ok, I've upgraded to PHP 5.6.33 and I upgraded MySQL to MariaDB version 10.2.12 and this is still an issue.

    I've also completely reinstalled the application and this doesn't work.

    Auto-assigning new tickets based on topics works fine.

    We have 2 different departments each with different email addresses. Do you think that could play a role? As in, responding to one instead of the other?

    Is there any way to add more logging? Whether it's custom logging to add to a class file or something to help see where it's going wrong?
  • You would check your PHP (or Apache error logs if you use combined) error logs.
    You would set osTicket logging to debug.

    We have 6 departments with their own email addresses and our assign on response works we use it daily.  However it makes me wonder.  What is your work flow for tickets?  What do you mean by "assign on response"?


  • I mean the "Claim on Response" feature:

    Enable this to auto-assign unassigned tickets to the responding Agent.
    Reopened tickets are always assigned to the last respondent.

    Our workflow is that a user will mail the helpdesk address which generates a ticket. We (the agents) will receive a notification informing us of a new ticket. We will respond by replying to the ticket and copy the user to inform them that we acknowledge the ticket and will work it.

    Our assumption is that responding to the ticket will assign it to the agent that responds so that we don't need to add a step of logging into osTicket just to click assign (especially because the response is added to the ticket thread already).

    Am I misunderstanding this feature? How do your 6 departments use this feature?

    And, I've scanned the log files and I can't find any messages related to this.

    thanks


  • Aha!  That's what I thought it might be.

    Agent email responses are not responses.  They are internal notes.  So they would not trigger the claim.  They have to repond via the UI for the feature to work.
  • So what is the "Claim on Response" feature? Who does that apply to?
  • or do you mean "claim on response via the UI"?
  • It applies to any Agent that responds to an unclaimed ticket by posting a response to a ticket via the UI.
Sign In or Register to comment.