Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

= Sign in emails...

I just got osTicket installed, very nice, but the emails that are auto generated have formating issues with line spacing and = signs all over the email.

Can someone help?

Comments

  • msnyder;9176 said:
    I just got osTicket installed, very nice, but the emails that are auto generated have formating issues with line spacing and = signs all over the email.

    Can someone help?
    could you post an example of your problem??
  • John Doe, A request for support has been created and assigned ticket #383198. A repre= sentative will follow-up with you as soon as possible. You can view this ticket's progress online here: http://support.domain= network.net/view.php?e=user@domainnetwork.net&t=383198. If you wish to send additional comments or information regarding this issue= , please don't open a new ticket. Simply login using the link above and upd= ate the ticket. Support Dept
  • Exact same issue here. Ubuntu server. Everything works flawlessly on a Windwos 2003 box. But the linux server has this issue no matter which tempalte I use. I have not changed defaults on any template and I use template copy to create all my templates.

    Here is an example of the email generated:

    Person,

    A request for support has been created and assigned ticket #24. A technicia=
    n will follow-up with you as soon as possible.

    You can view this ticket's progress online here: http://10.1.13.53/view.php=
    ?e=john.doe@email.org&t=24.

    If you wish to send additional comments or information regarding this issue=
    , please don't open a new ticket. Simply login using the link above and upd=
    ate the ticket.
  • Its a known issue http://osticket.com/forums/project.php?issueid=135

    I'm working on a solution.
  • Thanks... Let me know if you need access to my box for testing.
  • I've the old version of osticket 1.6rc4 and this issue don't exist. We're waiting for solution on this version.
  • Is there maybe a workarround?
  • I commented out the lines where the $mime class was encoding/manipulating the $body text in the email class and now the ='s are gone. YMMV and be careful when editing files, if you don't know php then don't do it :)
  • zalez;9548 said:
    I commented out the lines where the $mime class was encoding/manipulating the $body text in the email class and now the ='s are gone. YMMV and be careful when editing files, if you don't know php then don't do it :)
    Would you be willing to assist me in a workaround for my install? I need to put this into production, this is the only thing holding me back. ...and I don't know PHP.
  • peter;9196 said:
    Its a known issue http://osticket.com/forums/project.php?issueid=135

    I'm working on a solution.
    Is there any way that I may be able to assist? I'd love to get this working and I don't mind helping.
  • Howto

    Can you post exactly what you commented out and in what file please?
    My hoster will not change my email encoding to base64 to correct.
  • I was able to solve this issue without editing any files. Originally I had my Exchange 2007 server setup as a SmartHost in the main.cf file and I was getting the formating issue. To resolve, I populated the settings in the admin panel, under my email addresses for "SMTP Settings (Optional)". Since it said "Optional" and my emails where going through, I didn't fill in the settings. Once I did the formatting was correct.

    Please try this for your install and let me know if you have the same result.
Sign In or Register to comment.