Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.9.4-RC5 is now available! Go get it now

Keeps wanting Admin login

13»

Comments

  • I been thinking about it since I can't use Imap with them either which is a drag. I just REALLY hate changing hosts. So many crap ones out there. I was looking at a few....
  • Check your PMs.
  • Ok solution to this problem has been found....

    Signup with the host www.hostgator.com

    I am moving from GoDaddy today. HostGator even has OSTicket as a addon install from their control pannel!!!! :-)

    So This will fix the issue. Thanks for all the help!
  • HostGator even has OSTicket as a addon install from their control pannel

    Just be sure, pleasy verify that this is an up to date version and not something like version 1.3.

    I hope you are indeed able to run osTicket fine on the new server. It's about time :D
  • Just wanted to update eveone. Ok we made the move from Godaddy to HostGator and guess what.... No more login issues! Works like a charm now.

    VERY HAPPY!

    So if your having issues I have one word for you.... HostGator.
  • LMAO Ok I give up.... It just happen again!!!!!!!

    Now I know its the code and not the hosts. There is something really wrong with the code someplace.
  • If it was a code problem, which I'm not saying it's not, then every one would get this issue. I have never had this problem.

    bluetoof had this problem, and it was his host. He contacted them, and they fixed it.

    I'm gonna send you login details to a host I'm gonna set up for you. I want you to install it like you did on GoDaddy and HostGator. This will tell us if it's a problem with your hosts, or maybe even a browser problem on your side.
  • We have also installed 1.3 now to see if that works any better. Will report back.
  • Uhm, not to make it worse for you.... But 1.3 is known as a unstable version with lots of security leaks, bugs. etc. (I wish I could say this to someone who has no problem with RC4 :))

    Anyway using 1.3 is not a good idea.

    Further more I agree with Corey. The problems with RC4, can be a bug in the code, but that's still not 100% for sure. There are also people who have no problems with it.
  • damn figures, lol. I am not much of a coder but it just seems like this would be an easy problem to find. I mean this system does not look huge or anything... Don't flame me! Remember I said I am not much of a coder! lol ;-)

    This is just driving me nuts and there is really nothing more I can do outside of moving to ETicket. I found that on Google and they seem to be a break off from OSTicket. I tried it and it works perfectly however its not as easy to mod the looks of it though as OSTicket.
  • Don't know why the system singled you out. I am also interested in finding out what is causing the issue but I will need access to your installation. PM or IM me when you get a minute.
  • Just sent you a IM.
  • lol now its working again. I tell ya this thing has a mind of its own. :-)
  • Ok its doing it again if you want to catch it.
  • Worked for me!
    said:

    Try this:

    File: /upload/scp/login.php

    Replace:


    @header(\"Location: $dest\");
    require('index.php'); //Just incase header is messed up.
    exit;


    With:
    header('Location: http://www.yoursite.com/directory/upload/scp/tickets.php');
    exit();


    Replace 'http://www.yoursite.com/directory/' with your link information.

    Clear everything before trying to login, cookies, sessions, etc. Let us know if it errors or if it works.

    Awesome... worked great on my windows box! Thanks!
  • Is there a way I can just make it leave me logged in all the time.... I need to do something... Now I have some tickets I can not even answer cause it keeps going back to that login :mad:
  • voodoobamboo you can try a temporary solution from here:
    http://www.osticket.com/forums/showthread.php?p=2504

    Warning: This might raise security issues so make those modification at your own risk.
  • Many sites in PHP have errors. since the upgrade to Mysql 5.0.45 or PHP 5.2.5.

    The tickets no has problems for session.save_path? and the path is Okay. :confused:
  • Yeah I had to move to ETicket. Its harder to mod but so far no bugs.
  • It seems ETicket has had the same issue with this... Not a surprise as it was born from OSTicket.


    Turns out this may be the issue and answer.....

    "Turned out to be a php config issue on my server.
    session.save_path wasn't set.
    And the session.save_path didn't actually exist."

    Any thoughts?
  • said:

    You could try adding a .htaccess file to the root with
    php_value session.save_path /absolute/path/to/a/dir

    Where dir is a new folder and if I'm not mistaking this folder should be writable.

    This is something I posted in this thread before (a few weeks ago, see page 4), but I don't know if you tried it.
  • Same Problem

    Same problem here. Also using godaddy. I tried the suggestion of the .htaccess file and it throws a 500 error. Any further suggestions?
  • Seemed to be my connection. Tried it on a different computer and it works fine. No proxy running on either.
  • Last Page

    World of Warcraft has been last game i have really enjoyed and havent found any game after that worth to continue for more than 1h. Especially with console games where my PS3 has been working as blu ray player 99 of the time.

    Fallout 3PC is something else thought. It got all the basics right and really only thing it would need is longer story, larger area and more stuff. Ending is a bit iritating if you dont know whats waiting for you...

    8.5/10
  • Keeps asking for Admin login - 1.6 RC5
    said:

    Sounds like a session issue. You might want to check session path in php.ini and make sure it is set to a valid directory. You installed RC4, right?

    Having the same problem with 1.6 RC5. Hosted by www.daily.co.uk. Uses phpmyadmin2.11.9.2, MySql5.0.67.

    trying to change settings via the admin control panel. Occassionally new settings are saved but most times you try and save new settings you get taken back to the admin login screen.

    Can U help ?

    Regards,

    Mark Price
  • said:

    Try this:

    File: /upload/scp/login.php

    Replace:


    @header(\"Location: $dest\");
    require('index.php'); //Just incase header is messed up.
    exit;


    With:
    header('Location: http://www.yoursite.com/directory/upload/scp/tickets.php');
    exit();


    Replace 'http://www.yoursite.com/directory/' with your link information.

    Clear everything before trying to login, cookies, sessions, etc. Let us know if it errors or if it works.
    I am currently having problems with this on our support ticket system. I just tried this suggestion by Corey and my login.php script in the scp directory has messed up. It either loads view.php or has a blank screen. I didn't save a copy of the old login.php file anywhere. anyone have any suggestion? :confused: ,
  • Goddamn thing's driving me mad!

    I've tried 2 different servers (two computers with static IPs) - and still having trouble with login promts.

    I've tried to modify some files which were mentioned here. Nothing's happening...(((

    I can only surf inside of staff and admin pannels at the servers browser. When I try to surf at other PC - it fails.

    But, if there are people, who aren't disturbed by this problem - there must be a solvation. Maybe, it would be usful to view some (or all) server settings? Maybe some php functions are/aren't enabled/disabled?

    There must be a cure for this sickness!
  • Well, I've fixed it so far.

    I've found 2 files, which were with a wrong things. That were login.php and logout.php in scp folder.

    My "wrong" files were modified for translation into russian language. All I had to do is to replace my "wrong" files with the same files from original ZIP-osticket archive.

    Well, it worked. BUT only on latest XAMPP-server (yes, I'm lazy).

    The same ost-edition (with my replacements) didn't worked on Apache 2.0.x, PHP 5.x, and MySQL 5.1.
  • ugh.... I opened a 9 page can of worms... :eek:

    I just got ipage.com (unix) hosting 3 days ago...

    MySQL Version
    5.0.83

    PHP Version
    5.2.5

    I just downloaded the latest version osticket from your site this morning.

    Whenever I try to login I get: Authentication Required
    I tried several of the other suggestions here, but the only one that changed anything was:

    Solution:
    line 53 in scp\login.php, comment out @header("Location: $dest"); and try again.
    // @header(\"Location: $dest\");


    With this I get to atleast the main page, but if i go anywhere else i get wacked with the login again.



    header('Location: http://www.yoursite.com/directory/upload/scp/tickets.php');
    exit();


    This did nothing but give me a "page not published" screen, like the tickets.php file does not exist.

    This is all at:

    http://webacsa.com/osticket/scp/

    login info: [email]osticket@webacsa.com[/email]
    password: admin

    The original login.php file was re uploaded after all of my changes I made. So its fresh out of the box like I got it now.

    (I'm assuming its safe to post the login info to something that does not work atim) (also the login password is temporarily admin (I modified the md5 password key in my process of troubleshooting this)

    I have my php info available to pm if you need it.

    I installed phpbb3, and wordpress on this same server/host today and had no problems...

    Although I am having a similar login issue with net2ftp... I wonder if they are remotely related...

    I also have full access to my php.ini and .htaccess files on this webhost.

    Thanks so much for any of your time folks!
  • My Goodness - My Oh My !!!

    9 pages later I get to the end of this thread...

    4ice & Corey were on the money.

    (The 500 error may be a syntax issue in .htaccess)

    See the thread at
    http://www.osticket.com/forums/showthread.php?t=1386&page=2

    I had all the problems you guys have mentioned & It works for me.
    My Hosting Tech Support Fella nutted it out.
    (Before I saw 4ice & Coreys posts)

    Good Luck.

    Go to http://www.osticket.com/forums/showthread.php?t=1386&page=2
Sign In or Register to comment.