Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.9.4 (stable) is now available! Go get it now

Have trouble on setting pop and smtp

I got a problem when try to input the information of pop and smpt.
the email I want to use is under gmail. After I input all the informations for pop and smtp in the email setting, and click save, I got an error :

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Please help me to solve this problem. I have no idea what I can do right now.
And, the address is:
https://www.mydomain.com/Ticket/scp/admin.php?t=email&id=1

Thank you very much!

Comments

  • Im getting the exact same error

    Checked IMAP is installed using phpinfo()
    Logged into the server and then tried

    telnet imap.gmail.com 993

    Which connected ok

    Im using gmail via Google apps. Im getting nothing useful in the error log, other than there isn't a 500 error document....

    EDIT: Same if I try and JUST enter details for pop, or JUST enter details for SMTP
  • Check to make sure SSL is enabled/configured properly on your server. Gmail requires SSL to authenticate properly.

    Does it work with mail servers other than Google?
  • Small update, I've got SMTP to work with the following:

    host: ssl://smtp.gmail.com
    port: 465
    Use SSL: NO

    This now saved the settings, but emails didn't actually send. BUT then I could go back into the settings page and change the setting:

    UseSSL: YES

    Which strangely then saved?! Emails are now sending... I guess this means SSL is working but I can provide a link to my phpinfo() if you could check for me?

    I've just tried using the following on the receiving section - setting use SSL to no but it wouldn't save, I got a connection time out error in the osTicket control panel.
  • What port are you using for your pop3 connection? I believe it should be pop.gmail.com, port 995

    It still sounds like it might be an SSL issue on your server, since trying to use SSL for the pop connection causes it to break, but make sure the port is correct first, then try pop with 'use SSL' checked, in case trying to use SSL on the wrong port is what's causing the breakage*.

    *which seems a bit odd... seems like it should just fail, not throw a 500 error, but I had the same thing happen to me last week when setting up a helpdesk. It was related to something weird in the server's configuration, but I didn't have access to things to find out exactly what.
  • Conflict

    Conflict

    Google Apps does not work for me with IMAP + SMTP. Always try to POP + SMTP

    pop.gmail.com
    995
    yes SSL

    ssl: / / smtp.gmail.com
    465
    Authentication yes
  • said:

    Conflict

    Google Apps does not work for me with IMAP + SMTP. Always try to POP + SMTP

    pop.gmail.com
    995
    yes SSL

    ssl: / / smtp.gmail.com
    465
    Authentication yes

    Adding ssl:// worked for me!!!
    Thanks
Sign In or Register to comment.