Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Failed to set up a mail account

I am trying to configure an email account that requires authentication and I get this error:

authentication failure [SMTP: STARTTLS failed (code 220, response: TLS go ahead)]

Mail account does not require SSL or TLS ...

I day looking for information to respect and not get anything ..

mail account works .. active in Outlook simply requires authentication and it works perfectly. sends and receives with no problem.

I'm sure osTicket try to connect to SMTP using SSL

how could I fix it?

I hope I understand, I am using a translator.



  • IF you are using Outlook, then I am guessing that you are also running a Microsoft Exchange Server? What version of Exchange are you using?

    Exchange 2008 requires an SSL connection by default.
  • Using the 2004 version of Outlook.

    the fact is that my mail does not require SSL. both incoming and outgoing

    If you enabled SSL in Outlook, just not connecting.
    Like going on osTicket.
  • Do you have access to cpanel ? If yes, configure OSticket exactly specified in cpanel. It worked for me.

    "Best available authentication method is auto-selected based on what the sever supports."

  • I can not fix it.
    osTicket tries to connect to SMTP using SSL secure connection .. I've talked to a manager of my hosting server and tell me you can not try to connect to the account using SSL unless you get one. Obviously I can not connect to SMTP using SSL.

    do not know how to fix it .. without acquiring a ssl ..
  • Mail Account (Optional)
    Status : Enable
    Host :
    Port : 110
    Protocol : POP
    Encryption : None
    Fetch frequency : 1
    Maximum Emails Per Fetch : 5
    Delete messags : Yes

    SMTP Settings (Optional)
    Status : Enabled
    SMTP Host :
    SMTP Port : 2626
    Authentication Required? : YES

    This is my settings which is working. I didn't use SSL here. Hopefully this will work for you either. You can double check the port of your SMTP with your hosting manager.
  • Hi, I solved the problem and was just a coincidence ... and if it helps someone explain what I did ...

    walking in the \ include \ pear \ Net, I found the file smtp.php

    modify the line 467

    the line is something like:
    if (version_compare (PHP_VERSION, '5 .1.0 ','>=') & & (isset ($ this-> _esmtp [' STARTTLS ']) | | ($ this-> _esmtp [' STARTTLS '] == true)) ) {

    replaced it with:
    if (version_compare (PHP_VERSION, '6 .1.0 ','>=') & & (isset ($ this-> _esmtp [' STARTTLS ']) | | ($ this-> _esmtp [' STARTTLS '] == true)) ) {

    I guess what I got was that they connect to SMTP using TLS because that line it does is connect using TLS if the version of PHP is 5.1.0 and my version was that actually .. so I put the 6.1.0 (which does not exist) and connect without using TLS so now I accept the accounts and everything works perfect. :)

    Whether this change is not negatively affect other functions, but I really work. accept my email accounts and typing tests I have done some ticket and receive automatic email response with no problem. :)

    Thanks to everyone who wrote to me and thank you, jineedaj, i was testing what You told me but it was impossible ..

    I hope I have provided a good solution.

  • Problem still exists for 1.7 RC2

    I an confirm that I had the exact same problem with 1.7 RC2 and the "5.1 => 6.1" workaround helped.
  • edited March 2016
    Problem still exists in v1.9.12 (with PHP 5.6) but the "5.1 => 6.1" workaround works fine for me.

  • Also worked for me on 1.19.12.

    Only issue is I assume this is negating any type of secure link to the SMTP server, which is hosted on the same box should not be a big deal, but people should be away that using this workaround causes you SMTP communication to be unsecure.

    Perhaps osTIcket should provide an option with SMTP configuration for secure or non-secure connection to avoid the code change.
Sign In or Register to comment.