Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Staff Session Timeout

When I'm logged into OSTicket and it's been idle for a while (not sure exactly how long...15-30min?) and I try to create a new ticket or click on one etc., OSTicket recognizes that I've been inactive for a certain period of time and proceeds to log me out.

How do I make it so that OSTicket waits say 1 or 2 hours before automatically logging me out? I don't think it's overly complicated but would appreciate some guidance. Thank you.

Comments

  • In the Admin Panel you will find "Staff Session Timeout". Set it to zero to disable the timeout.
  • Just my 5c, but I've set the timeout to either 0 or 999 and yet have still had users report the timeout to me.
  • redcap;4120 said:
    Just my 5c, but I've set the timeout to either 0 or 999 and yet have still had users report the timeout to me.
    Maybe they are clearing their cache / cookies / sessiondata?
  • I doubt it, but will keep an eye on things in any case.

    I presume losing session data/cookies and the timeout are the only things that should boot a user off the system?
  • Page timeouts

    Is there any news on this one i have staff and clients set to 0 but still we have timeouts.

    the page is left open and they are not clearing cookies etc.

    Thanks,

    Tim
  • Incessant and annoying session timeout

    For me, this seemed to solve the problem:

    Bind Staff Session to IP: Uncheck the box.

    I access the net with an HSDPA modem. The IP often changes dynamically.
    I have been having un-interrupted admin sessions since applying this setting. My session timeouts are still left at the default 30 minutes.

    Hope this helps someone out.
  • I have the same problem ... any suggestions?

    Thanks!
  • This is funny. I've come here to ask the same thing as the above poster :)

    I had "Staff session timeout" set to 2000 (that should be minutes) and even with that, a staff user could be kicked out even after just 10 minutes. Then I switched it to 0 and today I've received another complaint. I wonder if it's hardcoded somehow?

    I've tried unchecking the "Bind Staff Session to IP", which I don't think will solve the problem for me, but at least I'll try it out.

    I'm using OSTicket v1.6.
  • I use v1.6 RC5 and there is not any 'Bind Staff Session ...' :)
  • Really? Check this just in case: http://i.imgur.com/EoCXpQm.png

    Why not updating to 1.6 final?
  • molul;38268 said:
    Why not updating to 1.6 final?
    I see your question and raise you a

    Why not updating to 1.7ST?
  • Lol! In my case, because my boss won't let me spend time on migrating to 1.7 (also not sure if there would be errors or problems with migrations).
  • No, I can not upgrade it. That's was part of the contract :) , because a lot of changes are made in the core files.
  • still no solution?
  • @andhipriono this thread is from July 2008 and version 1.6ST.  This version has not only reached end of life but has not been supported for a couple years now. You should upgrade if you are using this version due to a number of security reasons.  I also doubt that you are going to receive any answer(s) beyond this one.
Sign In or Register to comment.