Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

>>>setup / setup.inc.php on line 66

What is this error:

Fatal error: Call to undefined function bindtextdomain () in / home / domain.com, / public_html / os / setup / setup.inc.php on line 66

Comments

  • It says literally:

    the function "bindtextdomain" is undefiend (doesn't exist).
    It being called in the file / home / domain.com, / public_html / os / setup / setup.inc.php
    on line 66.

    Although I'm curious why there is a , in your domain name.
  • ntozier;44145 said:
    It says literally:

    the function "bindtextdomain" is undefiend (doesn't exist).
    It being called in the file / home / domain.com, / public_html / os / setup / setup.inc.php
    on line 66.

    Although I'm curious why there is a , in your domain name.


    What should I do?
  • osTiket doesn't use bindtextdomain as far as I know - would you mind uploading your setup.inc.php file?
  • peter;44190 said:
    osTiket doesn't use bindtextdomain as far as I know - would you mind uploading your setup.inc.php file?

    <?php
    /*********************************************************************
    setup.inc.php

    Master include file for setup/install scripts.

    Peter Rotich <peter@osticket.com>
    Copyright (c) 2006-2012 osTicket
    http://www.osticket.com

    Released under the GNU General Public License WITHOUT ANY WARRANTY.
    See LICENSE.TXT for details.

    vim: expandtab sw=4 ts=4 sts=4:
    **********************************************************************/

    #This version - changed on every release
    define('THIS_VERSION', '1.7-RC4+');

    #inits - error reporting.
    $error_reporting = E_ALL & ~E_NOTICE;
    if (defined('E_STRICT')) # 5.4.0
    $error_reporting &= ~E_STRICT;
    if (defined('E_DEPRECATED')) # 5.3.0
    $error_reporting &= ~(E_DEPRECATED | E_USER_DEPRECATED);

    error_reporting($error_reporting);
    ini_set('magic_quotes_gpc', 0);
    ini_set('session.use_trans_sid', 0);
    ini_set('session.cache_limiter', 'nocache');
    ini_set('display_errors',1); //We want the user to see errors during install process.
    ini_set('display_startup_errors',1);

    #Disable Globals if enabled
    if(ini_get('register_globals')) {
    ini_set('register_globals',0);
    foreach($_REQUEST as $key=>$val)
    if(isset($$key))
    unset($$key);
    }

    #start session
    session_start();

    #clear global vars
    $errors=array();
    $msg='';

    #define constants.
    define('SETUPINC',true);
    define('URL',rtrim('http'.(($_SERVER['HTTPS']=='on')?'s':'').'://'.$_SERVER['HTTP_HOST'].dirname($_SERVER['PHP_SELF']),'setup'));

    #define paths
    define('INC_DIR','./inc/'); //local include dir!
    if(!defined('INCLUDE_DIR')):
    define('ROOT_PATH','../');
    define('ROOT_DIR','../');
    define('INCLUDE_DIR',ROOT_DIR.'include/');
    define('PEAR_DIR',INCLUDE_DIR.'pear/');
    ini_set('include_path', './'.PATH_SEPARATOR.INC_DIR.PATH_SEPARATOR.INCLUDE_DIR.PATH_SEPARATOR.PEAR_DIR);
    endif;

    #Internationalization variables
    putenv('LC_ALL=' . LANG);
    setlocale(LC_ALL, LANG . '.UTF-8');
    bindtextdomain('i18n', 'i18n');
    bindtextdomain('i18n', '../i18n');

    // Choose domain
    textdomain("i18n");



    #required files
    require_once(INCLUDE_DIR.'class.setup.php');
    require_once(INCLUDE_DIR.'class.validator.php');
    require_once(INCLUDE_DIR.'class.passwd.php');
    require_once(INCLUDE_DIR.'class.format.php');
    require_once(INCLUDE_DIR.'class.misc.php');
    require_once(INCLUDE_DIR.'mysql.php');
    ?>
  • Well it looks like your running 1.7-RC4+. I recommend that you download the 1.7.1ST or 1.7ST and not try to use a buggy release candidate.
  • It looks like it's a customized install - contact the source of the download for help.
Sign In or Register to comment.