Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Custom Forms don't load when changing topic selection


I've setup custom forms and then against the relevant help topic I've set the form to be used for all tickets.  The problem is that when a member of staff or the client selects the topic it doesn't show the form until you click on the submit button.

How can I get the forms to auto load when you change the topic.

Many thanks,


  • What version of osTicket are you running?
    What web broswer are you running?

    I cannot replicate your report.
  • osTicket v1.8.1.2
    and browser is firefox 28.0

    Any other information you would need?

  • I don't have a problem with this (same version and browser) while opening a ticket. If this is an upgrade you may want to clear your browser cache.  If you're talking about while editing an existing ticket, then everyone has that problem. :)
  • Its a new installation although I have tried clearing the cache as well.  It's when a client is opening a new ticket.

    Is there any thing i can check, or where is the code that makes the page refresh on topic change?

    Thanks again.
  • Sorry I didn't explain before but to make it clearer - it does load the fields when i am logged in as a member of staff.  But not as a public user.

    This doesn't work    /root/public_html/open.php
    This does work       /root/public_html/scp//tickets.php?a=open

    Does that help?
  • Hmmm.   It works for me. 

    Are you using any javascript blockers or anything? 
    Are all the reports from a specific browser?
  • I've tried adding the site as a exception to allow java but no difference.

    It happens on all browsers that i have tried and also for the sake of testing I tried Outlook.

    Certainly got me confused!
  • Any further ideas on this?
  • I don't have any ideas... but I have reported this thread to the devs to have them take a look at it.
  • I'm told by osTicket that there must be something wrong with my code, I've now over written all modified files with original ones but it still doesn't work.

    Is there anything I can do here?  I'm in a real fix because our business needs this feature.

    If you want to see the error go to    and then select the revolution login setup topic you'll see that no additional fields load but if without entering information you go and click create ticket the field will appear.

    Please, if there is anything anyone can think of i'd be glad to know.
  • edited June 2014
    I created a test ticket to play and did not see additional fields.  Are you sure that you associated the forum with the help ticket?

    Admin panel -> manage -> Help Topics -> your topic: revolution login setup -> Custom form?

    note: I also never received a confirmation email with my ticket number, but I guess you can delete the ticket anyway.
  • sorry i forgot tot say that it will let you submit a ticket without you seeing the form if it is not set as required.  ive now set the single field in the form as required.

    could you try again?

    really appreciate it.
  • populated field field named "One" with value "ONEonlyONE"
  • did it load that just by selecting that topic?
    if so do you have a example site that you know works for me to try? just so see if its our machines?
  • What web browser are you using? I did it via FireFox (currently: 30, but it installed a new version this morning)
  • i've tried it on, latest chrome, 29 and 30 of firefox, and IE from 7 through to the latest and still not seeing the field until i click submit.

    I've checked its not the web filtering we have in place by trying to access outside of the offices here.

    does it rely on any java components or anything? just wondering what else may be different.

    for you does the field literally populate as soon as you select that topic? or do you have to hit submit at the bottom of the page first?

    Thanks for the time and effort.
  • Also i've just noticed that another installation of osticket that i have works fine -  I set this up exactly the same although i've themed the traffisafe version to the company branding.

    So that confirms its not my PC but something in what i think may be the data because i've overwritten all the modified pages in the Swift setup and it still doesn't work for me.
  • I think that it uses javascript to toggle a hidden div (but I haven't actually investigated) which an ajax call is made to populate.  I'm not sure.  IS there anything wonky in your web server (apache?) access/error logs?
  • OK.  I can't really see if there is any errors because it is a shared hosting.  Yes it is Apache.

    I'll check with the hosting provider and see where I can get to with that, unless there is anything else you think I should check.

    Thanks again.
  • same issue here with osTicket and latest Chrome or Firefox. When I select the Help Topic, nothing load, then I submit the ticket and it tells me there is a missing information (as I set my field as required) and then the form is complete.

    it is a fresh install on Ubuntu 14.04 with Nginx + php5-fpm
  • Just for the record: Nginx is NOT supported.
  • Just for the record: @Memes please start your own thread instead of highjacking someone else's.  Thanks.
  • and just for info, I installed Apache behind Nginx, it works properly. 

    As a quick thought, it would be worthwhile to have Nginx support rather than IIS (at least if I believe the stats I see lately in terms of number of server on Nginx). I am nowhere near to be that dev but I could test it if needed. 

    Sorry for hijacking the thread, but it was without answer for over 6 months (and still the one popping up in Google when I did my search)... Anyway, I won't do it again, I promise.
Sign In or Register to comment.