Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Failure Opening New Tickets.

Since upgrading to v1.9.0 last week, we have been unable to create new tickets. Obviously restoring from a pre-upgrade backup would resolve the problem, but I am hopefully for some support and an easy fix.

Users are able to get into the system fine, populate the ticket fields and everything appears to be working. However, that last step of clicking OPEN fails and goes to a error page HTTP 500 Internal Server Error.

All of my historical tickets are there, all of my data, drop downs, users, etc.. So, don't think it's a connection to the database..

Any help would be appreciated.


  • Hey mate,

    The best bet for help is to provide as much detail as possible, so the Dev's need things like:
    1. What is your system?
    2. Apache or IIS or something else?
    3. Tried using different browsers?
    4. Tried using Chrome's inbuilt developer tools - Ctrl + Shift + I 
    5. Tried using Firefox's plugin Firebug
    6. Any logs that can help?
    I'm a noob, but if I can I will help.
  • Hi @jetscape, please read this thread: Please read before requesting assistance and update your thread with information.  Also please consult your PHP error log and post any errors you see (or follow this to enable on screen errors, and report those: Thank you.
  • Not wishing to hijack this thread - but I have the same error.
    Activating the error reporting gives this error:

    Fatal error: Using $this when not in object context in *deleted by me*/include/class.ticket.php on line 2502

    Stuck now!
  • Just to add - the person creating the ticket is the admin, the email address on the ticket is that of the primary contact for the organization.
    Could it be an error where the system is trying to add the primary contact to the ticket when the email address of the user is the same?

    I tried removing the 'Add to all tickets from this organization' check box and the error went away...
  • I'll point this thread out to the devs.
Sign In or Register to comment.