Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

POP/IMAP fetch without SSL not working

Hi All,

I'm new to osTicket, I'd like to try it, but I'm ran into a problem right after installation that I can't solve.
I read everything I fount on 'osTicket e-mail problem' topic here and all over the net, but I can't find any usable solution.

The problem: I would like to setup POP3 e-mail fetch and outgoing SMTP for an e-mail address, without success.
I always get the following error in SCP at the top:

Warning: imap_open(): Couldn't open stream {}INBOX in /usr/local/www/osticket/include/class.mailfetch.php on line 139


Invalid login. Check POP settings

TLS/SSL failure for SSL negotiation failed

in the upper region and in the middle of form.

I don't want to use TLS/SSL, my mail server (running on another machine) using plain POP3 on standard port 110.
The account info I entered is working fine, I tested it with webmail and with telnet from the osTicket machine.
If this matters: the user name is the e-mail address (with a @ in the middle).
I also tried IMAP without success, too.

As you can see, I already modified the PHP code (moved /novalidate-cert after /ssl) with no luck.

When the error show up, the username and password I entered revert back to my admin account's username/password data, and my entered credentials not saved. I can't check that the correct name/pass is in use for the test.

My environment for osTicket:
- FreeBSD 9.2-RELEASE i386
- osTicket v1.8.0.2
- Apache/2.2.25 (FreeBSD) PHP/5.4.21 SVN/1.8.4 mod_ssl/2.2.25 OpenSSL/1.0.1e DAV/2
- PHP: 5.4.21
- MySQL: 5.1.72
- all req'd extensions available

Where to start over to solve this problem?



  • "TLS/SSL failure for SSL negotiation failed"

    Makes me think that either your server requires SSL and your not initiating a SSL connection, or Your trying to initiate an SSL connection and your server doesn't support SSL.  I would revert to stock code, and try again.
  • The server not requires (nor accepts)  TLS or SSL and of course I didn't set this mode in osTicket Admin, too.
    I tried with stock code first with no luck.
    I get the PHP imap_open manual, evaluated the possibilites and made the modification mentioned above but not helped.
    I reverted to stock code in the meantime, but it not works for me.
  • This works fine in my installation...
    Please provide your email settings in Admin panel -> Emails -> youremail under Mail Account.
    Feel free to sanitize your server name.
  • My settings on Admin Panel/Emails/Email/my email address:

    Email address: ''
    Email name: 'My Company Support'
    New Ticket Priority: 'Normal'
    New Ticket Dept.: 'Support'
    Auto-response: enabled (Disabled not checked)
    Username: ''
    Password: my_email_password
    Status: Enabled
    Host: ''
    Port: '110'
    Protocol: 'POP'
    Encryption: 'None'
    Fetch Frequency: '5'
    Emails per Fetch: '20'
    Fetched Emails: Move to: 'Backup' folder
    SMTP Status: Enabled
    SMTP Host: ''
    SMTP Port: '25'
    Authentication Required: 'No'
    Allow Header Spoofing: disabled (Allow email header spoofing not checked)

    Just to clarify: the POP3 server name is not, and the SMTP server belongs to a third entity: my ISP. The user name for POP3 is my e-mail address.
  • FYI: I upgraded to 1.8.1-rc1 and e-mail problem is the same. I can't connect to POP3 server.

    I can't figure out how to resolve. Tried other web-based ticket systems available freely, and the same e-mail box worked as desired. So, the problem not lies in wrong credentials, or POP3 nor SMTP servers.
  • I've asked the devs to take a look at this thread.
  • Thank you! I don't know how can I help the investigation. But I will answer the questions, if there will be any.
  • edited February 2014
    Thank you! I don't know how can I help the investigation. But I will answer the questions, if there will be any.

  • Im having same issue. Get same errors and have same setup.

    I have checked on open ports and my smtp is working fine, its "only" imap/pop thats breaking down for me. when i use imap setting i get another type of error and the admin module shutsdown, so i have to reload page.

  • Any solutions to this issue?

    I'm also trying to use POP/IMAP with no encryption, but getting "SSL negotiation failed".
  • By the way, the mail server accepts unencrypted connections.

    When looking in tcpdump, I see osticket tries to establish encrypted connection, although it's set to not use it in the settings.
  • I had this issue with my server, apparently after enabling the POP logging and IMAP loging I noticed it was using port 9933 for imap4 and 9955 for pop3 and it still wanted SSL even after checking that SSL wasn't required.
  • I'm really new to this so far I have an issue where tickets are not created when emails are sent. What's really throwing off in this scenario is that my other email accounts are working but not a specific account I keep on getting Invalid Login. Check POP Settings. Can't connect to exchange server:995: Refused. Can anyone help me on this?

  • edited September 2014
    You should create a "New discussion" for your issue, and be sure to include the details about your setup. And refer to Please read before requesting assistance
  • Also: "Can't connect to exchange server:995: Refused" your mail server is refusing the connection.
Sign In or Register to comment.